Nexus 5 - Problema de Instalación

  • Thursday, March 7 of the year 2.019.

    Nexus 5 - Installation Problem.

    Model: "NEXUS 5" (not 5x).
    Android version: 6.0.1

    1. Development options = Unlocked.


    3. "Debug by Usb" = On

    -Low menu, until read: "Debug by USB"
    -Activate: "Debug by USB" (Green lever activated).

    1. Drivers or Drivers: Downloaded and installed.

    (I downloaded the drivers from the "LG" manufacturer's page and installed them).

    I have also downloaded this:

    (The above link is facilitated by the program "ubports-installer.0.1.21-beta").

    -Installed: UniversalAdbDriverSetup.msi
    -Pc restarted.

    1. Bootloader = Unlocked

    2. Executed in Windows 7 - 32bit for flash:

    -Executed ubports-installer.0.1.21-beta.exe

    ... Phone switched on via USB cable, port 2.0.
    ... The program "ubports installer" does not detect the phone.
    ... Manual option, chosen "Nexus 5".
    ... Installation options: Channel: 16.04 / stable

    ... Click = Install.

    ... Off phone ...
    ... Turning on the phone, pressing and holding "Volume down" and pressing
    "On button"...
    ... "Startup Manager" menu appears ...

    -In Windows, I see that the "ubports" program is waiting, the message is:
    "Please reboot to bootloader"


    The system is waiting, the phone is in "Startup Manager" mode,
    ubuntu touch does not install, I only see the menu, with the android doll

    I can not continue the installation.

    Note: As I wrote above, in the "Development Options" menu,
    The "UNBLOCK OEM" option does not appear. If I can not unlock this menu,
    because it does not exist, this issue has to do with the problem of not having
    Could I install ubuntu touch?

    I need help.

  • Note:

    The usb cable works correctly on a "tablet" to pass files from "pc" to "tablet" and vice versa.

    The USB cable works correctly when you connect the "Nexus 5 Phone" in mode:

    -Access to files (I can see the folders of the android system, I access them).

  • @stropbu Firstly I have tidied up your posts a bit to make them more easy to follow. Hope you don't mind. The forum is conducted in English. For windows this version of adb can work better
    The oem is normally unlocked you can check by rebooting to fastboot. Hold down together until menu appears power button, volume down and up. If its not unlocked try the following
    cd Desktop/android-sdk-windows/platform-tools in command prompt

    fastboot devices
    you should see your device then

    fastboot oem unlock

    and that should be it
    Then try the installer again. If that doesn't work come back here or try our welcome and install Telegram group here

  • Saturday, March 9 of the year 2.019

    (Google Traslator > Spanish to English)

    -I have tried two different "Adb", one, the one proposed by the ubports program when trying to make flash, and another one, from the website of the manufacturer "LG".

    -The nexus 5 phone is unlocked from the beginning, I opened command console, pressing "Shift" and click right button in a place where there are no files, chose "open command console" and, try different things:

    On restart in fastboot mode:

    ... while the phone is unlocked ...

    -I managed to block it again from command console with the command:

    fastboot oem lock

    -After I unlocked also, from command console I made the order:

    fastboot oem unlock

    ... The phone restarted, it did a hard reset and nexus 5 remained in factory state.

    At this point, it is demonstrated that:

    -The USB cable works perfectly fine.
    -The driver's are perfectly well installed.
    -Windows 7, 32 bit, perfectly recognizes the phone because, when connecting by USB 2.0 from the nexus 5 to the PC, I see "nexus 5" as detected unit, I can enter the typical android folders.

    I have to also comment that, I tried to install ubuntu touch firmware, from:

    -Windows 7, 64 bits, updated.
    -Windows 7, 32 bits, updated.


    😶 If I have written, when I started this thread in Spanish, it was with the intention that, if someone with a Spanish language accesses the Ubports forum, it would be easier to follow instructions, anyway I had written in Spanish and then translated to English. In the linux forums there is always the same problem, it would be interesting to make a section in different languages, because this point makes many people who want to try different things, end up not doing them. 😶

    Regarding the link that you put me, I had difficulty from another PC, because the download did not work, now I'm on another PC and the download works, I do not understand anything.

    I'm going to download the "Adb" that you suggest from the link that you have put me before.

    I will comment on the results.

    (Of course, in English)😶

  • Saturday, March 9, 2.019.

    [Nexus 5 - Installation Made]
    [Windows Operating System = Windows 7 - 64 bit´s]

    @Lakotaubp: The drivers you suggested to me:

    <15 seconds ADB Installer v1.4.3
    ADB, Fastboot and Drivers

    ... they have worked.

    Ubuntu Touch is already installed, thanks for your help.

  • @stropbu Congratulations and welcome to Ubports I hope you enjoy Ubuntu Touch. Sorry I should have said yesterday we do have language groups you can find them all here including quite an active Spanish one

Log in to reply