Nexus 5 boot loop

  • Hello everyone,

    Here's a strange one...I had rebooted my Nexus 5 running OTA-7 stable and then installed some updates for Fluffy Chat and Calendar app, then I opened a private tab on Morph and was surfing the internet for about five minutes, then all of a sudden, my screen went black.

    I immediately pressed the power button and the screen lit up again for a second or two, then went dark again, so I pressed the power button again and this time, the "shutdown/reboot" dialog popup displayed a few times for a second and I tried to tap outside of the popup so that it would disappear. Then the phone shutdown and attempted to reboot- it got as far as displaying "Google" and an unlocked padlock against a black screen. After displaying "Google" for about eight seconds, the screen went black again and about three seconds later, the same screen displayed, but only for a half second.

    Now, every time I press the power button to turn on my phone, the same boot loop happens ("Google" for eight seconds, then again for half a second). I even tried to boot into fastboot (hold down volume down and power buttons), and the fast boot screen displays for only approximately one second, then the same boot loop occurs.

    I disconnected the battery and held the power button down for greater than thirty seconds in order to drain the electrical capacitors, let go of the button, and reconnected the battery in hopes that this would fix the issue; however, that hope was disappointed. I repeated this procedure again to no avail.

    Does anyone know what I should do next?



    Okay, this is weird. My Nexus 5 has now successfully booted twice and I'm writing this post update on the phone 😳🤔😎

    I have no idea why it's working now, but not before. I am grateful though.


  • Might this have something to do with the OTA-8 update?

  • Hey, rebooting on the Nexus 5 can have multiple causes. For example the software is broken. Then you are still able to boot into the bootloader. Hold the power down button and the power button for 10 seconds. Then you can flash your phone with the UBports installer. 🙂

    Another problem can be a hardware problem. The power button can be damaged and is always sending a "triggered" signal and so the phone is rebooting all the time. Sometimes you can fix this by doing this:
    And when this is no longer working, then you can still buy a repair set and try this:

    Most problems on the nexus 5 are very easy to repair.
    Have fun with your phone 😉

  • Agree totally with @Krille I have a Nexus 5 that really sulks if it's not charged and started regularly. Low battery power and the now legendary power button cause my issues starting.

  • @Krille & @Lakotaubp Thanks for the advice. I hope that it works😊

  • @Krille has it pretty well covered, but I'll add I went through the entire teardown/clean/fiddle process (also static pics here : ), without success.
    I'm wary of recommending it, but the thing that completely solved for me was HITTING THE POWER BUTTON WITH A HAMMER. Not super hard, but a nice solid hit right on the button. I arrived at this solution only after deciding the unit was otherwise bricked....

  • @circ I've used the edge of a table before now, and quite hard. It took a few attempts to get it to work. good stress relief though.

Log in to reply