Nexus 5 log files for libertine



  • Hi,

    I am trying to get a libertine application installed on the device. I have posted some time ago on this issue but I want to look at the log files in '~/.cache/upstart/' to try to make sense of why the libertine applications appear to install but fail to show in 'Desktop Apps' as some users claim to have successfully accomplished this. I have got it to install a package on OTA-7 (I believe) but nothing since.

    My question is...which of these log files do I need to open? (there are so many).

    Thanks everyone!



  • You probably need to look in ~/.cache/upstart/scope-registry.log or ~/.cache/upstart/unity8.log to see why the scope may not be displaying your apps.

    What apps did you install? Are they GUI apps with .desktop files that would normally appear in the dash on an Ubuntu PC?

    You can also follow the UBports docs to get a shell inside the container itself, and then verify if the packages are installed with standard commands such as dpkg -l and apt-cache policy, or examine apt/dpkg logs to find out more information.



  • @dobey

    I get the following repetition from the 'scope-registry.log'

    "No default department set in the .desktop file and no entry in the database for$"

    Trying to install a GUI package named 'grass' but also tried 'gimp' and 'geddit' through both 'adb shell' and 'system settings' -> 'libertine' (on the latter a continuous UT spinning circle).

    Not sure this is much help. I will try your suggestion 'dpkg -l'



  • @shapley That message in the scope-registry.log is fine, and from the main apps scope. You'll want to check the log immediately after refreshing the Desktop Apps scope.



  • Hi dobey,

    End of libertine (adb shell install) error:-

    E: Sub-process /usr/bin/dpkg returned an error code (1)
    ChrootContainer.py:126:ERROR:create_libertine_container(): Failure installing 'humanity-icon-theme' during container creation
    libertine-container-manager:123:ERROR:create(): Failed to create container:
    'destroy_libertine_container()missing 1 required positional argument: 'force"

    Not sure if this is helpful...



  • @shapley This suggests the container was not actually created, because it could not fully install the minimal set of packages required.



  • @dobey

    Finally... I've made some progress to get the Nexus 5 (partly) working with Libertine. The route which worked for me was as follows:-

    ~$ adb shell
    ~$ libertine-container-manager create -i libre --n libre
    This builds a container called 'libre'
    ~$ libertine-container-manager install-package -p libreoffice -i libre
    This will install 'libreoffice' in the 'libre' container

    Just one problem left... when you click on any of the desktop icons your screen is filled with 'splash' screen 'libreoffice' icons but nothing launches. Think someone else on this forum had the same issue.



  • Sorry guys...false alarm. tried this a second time but got this error after which it deleted the container.

    E: Sub-process /usr/bin/dpkg returned an error code (1)
    ChrootContainer.py:126: ERROR: create_libertine_container(): Failure installing 'humanity-icon-theme' during container creation
    libertine-container-manager:123: ERROR: create(): Failed to create container: 'destroy_libertine_container() missing 1 required positional argument: 'force''

    Back to square one!


Log in to reply