Nexus 5 Convergence don't work



  • When I connect my nexus 5 (OTA-8) to an external monitor (TV or computer) with a slimport adapter, the UT screen is played on the external monitor, a message appears on the phone screen saying that it can be used as a touchpad for drive the mouse pointer. But when I tap the cell phone screen, the message disappears and the screen turns gray, no longer responds to touch commands, and the mouse pointer does not appear on the external monitor screen. As none of the external monitors was touch screen, it was simply not possible to use the converging device. In the UT tweak tool I used the 3 methods available in Usage Mode and always got the same result. Did not work!
    Soon after disconnecting the monitor Scope Apps appeared empty and only came back after the UT reboot.
    Some kind of setup?
    In the searches I did I did not find a solution to the problem, unfortunately.



  • It is a very well known issue for a long time. and unfortunately, it is specific to the Nexus 5 which is the best device to try out external display (desktop mode). It works fine on Nexus 7 2013 when I last tried (vivid? 😄 )
    https://github.com/ubports/ubuntu-touch/issues/301

    For now, you'd have to use a bluetooth mouse, the OSK works fine but I'd still recommend using bluetooth mouse + keyboard for better experience.
    As for the other bugs you encounter when switching back and forth in desktop mode, sadly they also happen. It's not a stable feature yet and hasn't been touched for a long time. Hopefully once we get the new Unity 8 and mir, someone can take a look on this feature and improve it and that Android Q is about to officially have desktop mode 😛



  • Thanks for the answer.


Log in to reply