No Caldav synchronization of a freshly connected calender after reboot



  • @hummlbach

    Hi, that's it. Moreover, when I add or change an event on the server I do not receive those events on ubuntu touch. This only works when I add the calendar an do not reboot the system anymore.
    I would be very glad if somebody could give me a hint in order to have a fully synchronized calenar with the phone.



  • it actually works quite well in the way you do it. I can reboot without loosing the synchronization with a "generic caldav server/account".
    Maybe you have to give more details. Which device do you have? which are you on?
    And I must look up which logs we need... But later cause I'm on the road now.



  • @hummlbach Thank you for your help with this issue. I use the Fairphone 2 with Ubuntu 16.04 (OTA-8).



  • @karstong i also have fp2 with ota-8, but no problems with caldav sync after reboot...



  • @tommiedom Okay. What could be the problem with my distro ? The calendar works with Ubuntu Thunderbird, with Windows Thunderbird and with Android calendar. Only Ubuntu touch does not work with it. Which logs should I consider?



  • I am experiencing similar problems where Calendar is no longer syncing via CalDav to my NextCloud calendar hosted on OwnCube. OnePlus One - 16.04 RC (2019-W13).

    Best regards,
    Steve Berson



  • @karstong the relevant log is ~/.cache/upstart/sync-monitor.log. (It won't log the password, but it has your username and the server you're using inside. So idk maybe you prefer to not post it here publicly...(?))



  • @hummlbach I want to chime into this too. I will give you more info, but right now not on my PC and difficult to give logs. I am syncing with Nextcloud accounts, and calendar has been a bit of 'hit and miss' .



  • @hummlbach in the sync-monitor.log there is nothing that could be interesting - only 6 lines. But I installed the Logviewer. There you can find logs from "aplication-click-com.ubuntu.calendar_..." and "application-click-logviewer.neothethird_logview..." which relate to the calendar app. In the first I find a lot of errors. Unfortunately, I can't export or copy the entries to the clipboard. Here is just a short example:

    "(process: 9179): dconf-CRITICAL **: unable to create file '/run/user/32011/dconf/user': Permission denied. dconf will not work properly."

    OR

    "error calling result "An AppArmor policy prevents this sender from sending this message to this recipient; type:"method_call", sender="1.141" .... etc"



  • I had the same issue with a owncloud calendar. When I created the generic calendar on my phone, I provide an url like that:
    http://xxx.xxx.xxx.xxx/
    and that's all. It it the owncloud url and the phone could find all the calendars I created on owncloud. BUT, no synchronization after that, from owncloud and also from the phone to owncloud.
    So I deleted this account and create again a generic caldav, but this time, I provide a more complete url, like that:
    http://xxx.xxx.xxx.xxx/remote.php/dav/
    This url is given as a link into the owncloud's calendar.
    Now it works very fine. Hope it will help you.



  • Just a note that I was able to fix my Calendar sync problems - seems it was user error. I had both Generic CalDav and NextCloud accounts enabled going to the same OwnCube hosted service - by deleting both and by re-enabling just the NextCloud account Calendar is now syncing as it should.

    Best regards,
    Steve Berson



  • @Teigneux Hi, actually I use an exact URL to my calendar just as you mentioned in the end of your post :

    xxx/remote.php/dav/user ...

    Login + Password

    As I said, when I connect the calendar with Ubuntu Touch therese is absolutely no problem with synchronisation. Only after a reboot of the phone synchronisation fails .

    Moreover, I do not have any other online accounts like Owncloud connected with UT - only this one generic caldav .



  • @karstong ok, your problem looks very different, it is more like a bug than a configuration problem. Good luck!



  • @karstong you either have very very special case, or what seems more likely, something is messed up with your installation or setup. So either you provide full logs s.t. maybe someone can get an idea whats faulty in your case or you cleanup the calendar backend config manually and reinstall your device... 😉



  • I too had problems with the built-in nextcloud calendar sync on my Pro 5. As I already had nextcloud contact sync working (through bash scripts), I deleted my nextcloud account on the device and added the account through syncevolution from the terminal (similar to my contact sync).

    I am now running a bash script manually for two-way sync of contacts and calendar.

    However, probably after an OTA update (I am on devel), my calendar sync started giving errors. After deleting the syncevolution database and config for the nextcloud calendar and recreating them, sync works fine again.

    The one thing I haven't been able to figure out is how to run a syncevolution cron job. It seems that the X server requirement is preventing running these commands in the background. But syncing manually doesn't take that long, so that's what I will use for now.



  • @tomoqv said in No Caldav synchronization of a freshly connected calender after reboot:

    The one thing I haven't been able to figure out is how to run a syncevolution cron job. It seems that the X server requirement is preventing running these commands in the background. But syncing manually doesn't take that long, so that's what I will use for now.

    Same with me. I manually trigger the command in the terminal and everything gets synchhronised



  • Thanks to all for your replies and sorry for the calm from my side. My son was born last week-end so there were plenty of other interesting things 😉

    Since I am not a pro user and am not so familiar with the terminal I would be happy if you could explain how to manually trigger the command in the terminal. Thank you again.

    For the moment I do not have the time to freshly install UT on the device.



  • @karstong hey congratulations!



  • @Teigneux Thank you! It's just wonderful - I had no idea...


Log in to reply