Using apt to install package



  • I was trying to use the terminal and installing some aappsuch as zsh and tmux, but I can't find any of those even after making my image writeable. Is there a step I need to to to be able to install app?



  • I'm running zsh successfully. It was a 4 step installation.

    1. Make root writable. sudo mount -o remount,rw /
    2. Update packages info. sudo apt update
    3. Install zsh. sudo apt install zsh
    4. Make root great read only again. sudo mount -o remount,ro /

    On FP2 I had troubles recently with insufficient space, which I solved using the cache purge (/var/cache/apt) and tune2fs techniques described in https://forums.ubports.com/topic/1676/development-testers-for-anbox/119.

    And I failed to make zsh the default shell environment. Maybe somebody here knows how to.



  • @jezek omg thanks, I switched from ubuntu to arch 4 years ago and totaly forgot about the need of apt update XD That was the missing step now all is good!



  • @jezek so after multiple attempt I always get insufisent space despit the apt purge + tunel2fs. Is there any other way to be able to use the space from my phone? ( good lord the UT partitions are complicated)



  • @Aurze you can mount-bind apt cache archives to some place with more space. See https://forums.ubports.com/topic/2767/ubports-with-a-jbl-go-speaker/7 for more info.



  • The rootfs is readonly for a reason. Phones aren't PCs. If you need to install additional packages via apt/deb, the supported way to do that is within a libertine container.



  • @Aurze If you really want this, you can resize your rootfs. There's command somewhere here in the forum.
    But beware that is isn't supported and an OTA update may make your device non-bootable. A reflash will most likely revivie your device though but everything you did in your rootfs will be gone.
    As Rodney said, UT isn't like a traditional linux PC. It is still a phone 🙂



  • Isn't resizing the rootfs a bit extreme?

    I've been experimenting with libraries in /vendor/lib/egl
    see: link

    I once used the method to move the apt archive to /userdata and try to install clickable on my phone. The trouble I ran into is the working directory ran out of room to decompress the docker files, and as I'm not sure where that is I never did get farther. Seems like it should work fine if you can move all the necessary folders into the writable partition.

    Idealy I think support for a casper type file like live usb Ubuntu systems can do would be very powerful. Allowing these sorts of instalations with a fallback to just boot the untouched OS image in case of trouble would be ideal in my mind.

    Mind you I'm only recently relearning Linux systems, and really don't know what I'm talking about.✌



  • @dobey That does make sense and thanks to put it that way, but I was trying something. That I finally got really close but turn out docker on UT is not happening anytime soon.

    Your Linux kernel version 3.4.0-cyanogenmod-g2669fa0 is not supported for running docker. Please upgrade your kernel to 3.10.0 or newer.


Log in to reply