Issue with SD card

  • As I mentioned in a previous post, I can't have access to SD cards on my BQ M10 FHD running UBTouch. Here is the summary of the observations:
    – the 64 GB card is visible in External drives,
    – but it does not appear in File manager.
    – after many unsuccessful attempts, I was also able to format it using External drives, but it still doesn't appear in File manager.
    The card (call it SDa) is visible on desktop computers (Asus running 16.04 LTS and MacBook), I could copy some files on it.

    I swapped the card with another (64GB as well) one that I use in my Android phone (call it SDb). When I insert SDa in the phone, I see it and its content on the phone. And SDb is no more visible on the M10 than SDa was.

    Also, when I hook up the phone to the MackBook, I see the content of the SD inserted in the phone using Android File transfer, but when I hook up the M10, I don't see it.

    In conclusion, there is nothing wrong with the SD card. And I see only three possible explanations for the problem on the M10.
    – the SD card is not mounted (and I so how can I mount it manually?), or
    – the M10 cannot manage 64GB SD cards (it may be limited to lower capacity SD cards?), or
    – there is a hardware problem on the M10 (unlikely in my opinion as the card is visible in External drives), in which case I should return it to Amazon.
    To make sure that it's not a hardware problem, I guess the best would be to check that the card is visible on Android, which means reinstalling Android. Are there instructions somewhere on how to do that?

    All advices/suggestions will be greatly appreciated.

  • I just ejected it and inserted it once more, and all of a sudden, it now appeared!
    Computer mysteries 😉
    Problem solved.

  • Bad luck, after rebooting, the SD card was gone again!
    Ejecting and inserting once more, it showed up again. I guess there is an electrical contact problem.

Log in to reply