LGE Nexus 5 stuck on Ubuntu 15.04 r3



  • Hi,

    I installed my Nexus 5 with ubports more than a year ago. According to "System Settings" -> "About" it is running Ubuntu 15.04 (r3), stating "Last updated "1/3/70" (which maybe means "never").

    Pressing "check for updates" says "Software is up to date".

    However, on devices.ubuntu-touch.io latest stable version is listed as 16.04.

    In "channel settings" I have selected "Stable". I see no way to request the upgrade to 16.04.

    Any ideas on how to get my installation up-to-date?

    Thanks and cheers,

    Dave



  • @Dave Try changing the update channel to development and see what happens. Not sure why this hasn't updated as the release was months ago.
    Edit: If that does not work try this https://forums.ubports.com/topic/1599/how-to-manually-upgrade-from-ota-3-to-ota-4 Please note the DO NOT choose WIPE warning.



  • @Lakotaubp ,

    just switched channels to development and back to stable. It then started downloading an image. Though finally it failed "Update failed,; signatureError: ...".

    Will retry again later and if this can't be made to work, commence with the manual upgrade procedure you linked.

    thanks,

    Dave



  • Yes, I retried, the "stable", channel download (Versiwon 3) reproducibly fails with an "Signature Error". The development channel download (Verison 287) works and offers an "Install..." button once done.

    Maybe will add another forum topic about the signature error.

    Dave



  • @Dave I think most of those issues will have been covered already as the update to 16.04 is nearly a year old now. I would get upto date with everything and check all is ok and go from there. If you are still having issues please come back here for help.


Log in to reply