Signature error when updating via System Settings from 15.04r3.



  • Hi,

    running an ubports installation on LGE Nexus 5, "stable" channel ( 15.04 r3).

    The download of the new stable image under "System Settings" -> "Updates" fails with :

    Update failed
    SignatureErorr:
    sig path : 060f5c1283d44... /android/cache/recovery/device-f43cba6c627...
    [..]
    keyrings: ['56b9554d8355b87653425cb..'] ['/var/lib/system-image/keyrings/image-signing.tar.xz']
    

    [..]

    If I switch to the development channel, I do get a successful download (but don't want to install development version on my phone). If I switch back to stable, the download restarts and fails with the same error.

    Any idea what's broken? Is this a local or server-side problem?

    cheers,

    David



  • @Dave hi, 15.04 is not supported anymore, the current stable version is 16.04 (OTA-9).



  • @advocatux , yes that makes sense. However, what's the recommended way to upgrade to 16.04 stable, in spite of the signature error I get?



  • @Dave there are several ways to do it, you can use the installer (without checking the wipe option) for example, or you can adb to your phone and run sudo system-image-cli -vvvv --switch 16.04/stable



  • Hi @advocatux ,

    I ran into the same "signature error", attempting to update my Aquaris 10 FHD tablet. As I don't mind breaking the tablet (as opposed to my phone), I just attempted to upgrade using the development channel, which worked (i.e. no signature error), then once that was running switched back to the stable image, and this time no signature error as well.

    Working nicely now, no problems, some bugs I encountered with 15.04 seem to be fixed with that release. Very happy. Will attempt the same procedure on my phone.

    Dave


Log in to reply