Any reason why flashing Ubuntu touch on Nexus 10 wouldn't work



  • Hi,

    I bought Nexus 10 for sole purpose of testing out Ubuntu touch.
    I tried first with official Ubuntu build following: https://developer.ubuntu.com/en/start/ubuntu-for-devices/installing-ubuntu-for-devices/ using devel channel.
    I wasn't successful - after all the process seeming to go well at the end at reboot only sequence "Google", then for part of a second Ubuntu sign and then icon of a chip with sign "This phone needs restoring from a PC...." appears.
    After failing with Ubuntu images I tried Ubports images and same thing happens - flashing process appear to go well, but at the end after rebooting "This phone needs...". I tried "stable", "rc-proposed", "devel-proposed" channels - none successful.
    I doubt I'm doing something wrong, as I successfully flashed several Nexus 4 phones.



  • I'd appreciate any help - did someone actually successfully installed Ubuntu Touch on Nexus 10 lately - with later images?



  • I found the solution. It might be good, if you mention it in the installation instructions.
    During installation, after image has been loaded into device it is necessary (I assume only for Nexus 10 devices with 16 GB flash) to execute following command to free up memory:

    ubuntu-device-flash --clean-cache touch

    After I did this, installation worked on first try (after previous 10+ tries without this command).



  • sorry, this solution still doesn't work on ubports images - only on official "devel" images.


  • Administrators

    Are you running it with --bootstrap?



  • Same problem here. Only the official "devel" images are working. With the Ubports images I'm running into the same problems like user gspublic. I tried with and without --bootstrap. The official "rc-proposed" images are ended up in a boot loop showing only the "google" screen.



  • @mariogrip said:

    Are you running it with --bootstrap?

    yes, command recommended on this site for this device:
    sudo ubuntu-device-flash --server=http://system-image.ubports.com touch --channel=ubuntu-touch/stable --device=manta --bootstrap
    as mentioned by luckychild, only official "devel" images are working.



  • Also friendly advice - do not update "File Manager" app, as it will render your "File Manager" useless.



  • Where can I find the source code of the running official devel image and the currently not working official rc-proposed image (which seems to behave the same like the Ubports image) ? The old devel image is really outdated and I would like to get running the current rc-proposed image. In a first step I would try to find out where are the changes and what leads to the boot loop. It is really annoying that BQ comes out with an ubuntu M10 tablet while the Nexus 10 has a better screen but the working ubuntu version is outdated and the current version isn't working :-( Is there someone in the community who would support me with knowledge to debug the current rc-proposed images ?



  • Not sure if it's so simple:
    https://wiki.ubuntu.com/Touch/Building

    I'm frustrated too, that nexus 10 isn't supported, however I think it's intentionally not.
    Cannonical doesn't want to make competition to BQ with Nexus 10, which isn't sold anymore.



  • Sorry for bumping this thread, but has anyone gotten this working yet?
    i'm still getting the "This phone needs restoring from a PC...." message.

    it's really frustrating to see Nexus 10 listed as 80% operable, but installation is stuck for almost half a year now...

    if somone knows how, please help out here.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.