[solved] Can not install ubports on krillin again



  • Hi,
    I had some issues with updating some apps on my E4.5, so I decided to reinstall ubuntu with the ubports-installer. Everything seems to work during the install process and at least the installer said "It's done and it's safe to remove the phone".
    But when I disconnect the phone and start it up, there's only the BQ-logo, nothing else. I can boot to recovery without problems.
    After several retries (with stable, devel, edge) I found out (by pressing Volume+ in Recovery-Mode when the installer is transfering the files), that the last message is:

    "Keyring expired: /cache/recovery/image-signing.tar.xz"
    "Ubuntu update complete"

    Could it be that this Keyring is the reason why my E4.5 stuck on the BQ-Logo and won't boot up?





  • The messages paulusasol mentioned are almost the same I can see after installing. But because of the smaller display i only see the last ones (beginning with "Loading keyring: image-master.tar.xz").
    But how can I check the date on my phone when it's not booting anymore? In the recovery-menu there's no option for that. Or did he mean changing the time/date on the computer that was used for flashing?

    PS: I found some hints using adb for setting date/time on the device. When I'm at home I will check this.



  • I've checked time and date on the device but it seems to be correct...

    Here are the messages from the same log.



  • It's working again. I don't know what was the problem but I solved it this way:

    1. Installed an old 15.04 UT-Image with the SP_Flashtool
    2. After that the phone was able to start again
    3. Upgrade from 15.04 to 16.04 (OTA-9) with the latest ubports-installer
    4. Device was still able to start

    After that everything seems fine again

    Thanks for helping.


Log in to reply