Porting Ubuntu Touch (@UBPorts) to tenshi (BQ Aquaris U Plus)



  • @Lakotaubp it's a long time i have struggled to turn it OTA ready (as to get it booting from systempart). I got it once, but in a couple of hours it crashed and i was not able to repeate it anymore.
    I tried to dd rootfs (with system.img inside) as well to cp it to /dev/mmcblk0p24, but somehow it fails to boot from this partition



  • @Guf Thanks for the reply. I am getting one for next to nothing 🙂 So what is the best way to install UT? Do the instructions above still apply or have things altered.



  • @Lakotaubp by using halium-install to install it on datapart (data partition), it works really fine as I have used and tested it myself, as daily driver, for some months.
    I am sharing important stuff with you:
    rootfs
    system.img
    and halium-boot without OTA-compatibility (at the moment)
    To install these three, you need to exec:

    adb push name_of_rootfs.img /data/rootfs.img && adb push name_of_system.img /data/system.img
    

    once you are in TWRP (and previously unlocked the bootloader).
    Then, you reboot to bootloader and execute:

    sudo fastboot flash boot name_of_halium-boot.img && sudo fastboot reboot
    

    Wait for some seconds and you should get UT spinner running.
    I give you the rootfs.img because with this img also camera works, and recently hands-free speakers too.



  • @Guf Thanks should have it by the weekend, then just need to find the time. Will download the bits and get ready. Thanks again.



  • @Guf said in Porting Ubuntu Touch (@UBPorts) to tenshi (BQ Aquaris U Plus):

    To install these three, you need to exec:

    Is there a need to clear and format partitions as on OP3. First attempt reboots to powered by android screen and stops there.



  • @Guf All sorted I have UBports up and running just need to add accounts and take it for a run. Thanks again. This is a nice size phone.

    Edit: During setup I was not asked to set a password, so how do I get past the lock screen without going through it all again phablet does not work.
    Edit 2: Double checked and reinstalled and no request for password setup. Language setup, wifi, device name and location and then into OS. So without password can't change setting or use UTTweakTool.



  • @Lakotaubp password is 1234



  • @Guf 🙄doh. How to feel very silly. Must have tried every combination of everything but 1234. Still plenty of time to get it set up now. Thanks.



  • @Guf Thanks again for this and yes I did miss the code right at the top of this thread as well 😞 Still have most things set and and working during the weekend, so going to use it all day today. Still need to get camera going but that will be down to me again prob rushing. Battery life seems to be very good compared to OPO and OP3. Couple of quick thing if I may first, MTP. Uplus shows up as a wired connection Network on laptop but that's all except when in TWRP recovery when adb works. Is that correct, and the current status of the finger print sensor. How is that going.
    Again thanks for all the work on this. It's a nice size of phone for me and it's really quick on UT again compared to OP3. This is my first halium ported device (that keeps TWRP) so all new to me.



  • Couple more things just to check. Latest version of uNav not picking up GPS or asking for permission to do so, anyone else with this. Also installed indicator weather and on reboot lomiri (unity8) reported a missing file. So reinstalled everything and now time and date is not setting other than to Madrid. Did this last time then suddenly worked so going to keep trying as seen this elsewhere.
    Still can't sort camera, just blank screen but overly bothered by that yet.



  • @Lakotaubp

    sudo dpkg-reconfigure tzdata
    

    in order to set you time zone properly.
    GPS should work with uNav, but you need to be outside your house for the first attempt and it might need 15 min to get connection.
    Regarding Lomiri with missing file, this is a known issue (that you can experience in other device), so please try an older edge rootfs.img or devel one.
    Camera is working with older version (3.1.0) but the issue came from rootfs packages, rather than from camera-app itself. I noticed that with my available rootfs.img it works on 2GB/16GB model, but not woth 3GB/32GB ... that's weird, isn't it?
    Still working on MTP, maybe it doesn't work because it hasn't still activated CONFIGFS, need to investigate.
    Yesterday I again experienced booting from /systempart, so I was focused on OTA-compliance because it will be the big step further to promote tenshi as community dev.
    If you want to try it, go to twpr:

    guf@GufBookPro:/media/gufdata/halium-7.1$ adb shell
    # mount /dev/block/mmcblk0p24 /tmp/
    # mount -o loop /data/rootfs.img /mnt/
    # cp -a /mnt/* /tmp/ && cp /data/system.img /tmp/var/lib/lxc/android/system.img && sync && umount /tmp && umount /mnt && sync && reboot
    

    Then, stop and go to bootloader and execute:

    guf@GufBookPro:/media/gufdata/halium-7.1$ sudo fastboot flash boot halium-boot.img && sudo fastboot reboot 
    

    (please, use the following halium-boot_tenshi_systempart.img



  • @Guf Thanks for the reply. uNav worked till the update the other day then stopped, which seemed odd. Weird issues with cameras I'm used to with the OP3 and OP3T. Still really enjoying this device so time to try your other stuff this weekend. Thanks again.



  • @Guf Hi... I try to boot with systempart. The phone do not boot. Still save in the bootscreen.
    Before that i try to boot with your rootfs, system and boot img.
    Phone works without camera. Now i wait for next steps. Thank you again for your good work.



  • Still can't get uNav to work, hangs waiting for GPS. App does not ask for permission to access GPS and nothing in app permissions for location. Microphone shows two, but nothing in Location. The web app of here maps asked for permission when I tried it.. Anyone have any ideas? am using edge rootfs from 13/10 and system.img and halium-boot 20200913.img. Also have been using rootfs 20200913 with same results.



  • @Lakotaubp Hey, i have tested uNav and PureMaps on two devices (16 GB and 32 GB). GPS work fine. It need some minutes and free space (not inside a house) to receive and acivate signal. Then it work very good. Installed is halium-boot-20200326, system-20200326 and actuell rootfs from this page https://ci.ubports.com/job/xenial-rootfs-armhf/ with halium-install.
    Camera displayed and switching sharp is possible. But not save the photos. If i need a photo, i use screenshot. 😅😅
    Microphone works, but
    very quiet. You can use uVolMan to make it louder.
    Next days i will change from Xperia to Uplus as daily device. Hopefully the camera will work next time.



  • @Nandel I'll try that rootfs first and see then try the other bits if no change. Tried the outside thing still nothing will give it another go. Worked once so will sort in the end. Being cheeky now can you send the link for the system image, it'll make sure I do get the right one. Having bad time finding things lately.





  • @Lakotaubp For more questions and faster answers: https://t.me/DH5FB



  • Hi guys, we are telegram channel TENSHI to comment too



  • @Josele13 Should there be a link?


Log in to reply