Trying to Install UT on Nexus 4

  • Using the automatic UBports installer. Installer automatically detects the Nexus 4, I select the installation options, and the phone goes to the UPports recovery screen. The installer says "waiting for device to enter recovery mode", but never recognizes that the phone is there.

    I can restart the phone, and even navigate back to the recovery screen without the installer responding. However, when I turn the phone on normally - not the recovery screen, just the regular home screen - the installer decides that's what it wanted and then tries to continue the installation. It verifies the files it has downloaded and then tries to push them to the device, where it gets the error "Adb push error: Error: Command failed: adb -P 5038 push" ... "remote Permission denied".

    Now I presume that is because it's supposed to be on the recovery screen when it tries that, but I could definitely be wrong.

    So, answers to any of the below would be helpful,

    1. does anyone know if this error is because the phone is supposed to be on the recovery screen for the adb push command?
    2. does anyone know why the installer isn't recognizing when the phone is on the recovery screen?
    3. does anyone know where the temporary files the installer downloaded are saved? Because if I could delete those I could get the phone back to the recovery screen before the installer tried the push command, and I figure that might be worth a shot.
    4. since I can access the recovery screen now, and it has options like "install ubuntu zip" and "install ubuntu preinstalled" is there another way to install UT with these options that goes around the installer entirely? (I took a look at the manual installation instructions but didn't really get it.)

    Thanks for any help.

  • You need to grant permission on the device for ADB to work. You should see a smallish popup window on the device screen asking you to do that. Once done that will fix it.
    Your device needs to be in developer mode (tap build number 7 times if Android) MTP on and adb debugging. All under developer settings. You might need to Factory reset under adndroid options and start again.

  • Thanks for the reply.

    Alright. Permission was granted already, but I tried revoking USB debug permissions. It asked for them again when I started the installer. I granted them, including the checkbox for future requests from this computer. Installer hit the same error as before.

    MTP is on. I toggled it off and on and tried again. Same result.

    Performed a factory reset. Re-enabled USB debugging and granted permission. Still got the same error as before.

    In case it helps:
    phone: Nexus 4
    phone OS: Android 4.4.4
    computer OS: Windows 7
    drivers: as per recommended "Google" option in Nexus Root Toolkit
    abd and fastboot: from Android Studio

  • @techisfun Try 15 sec adb from here for Windows also UBports Installer 0.1.09 and 0.1.12 worked well with windows 7 if they are still available haven't used them or windows in awhile. is your installer the very latest 0.2.3 beta? Also remove any other phone drivers from your pc/laptop.

  • Installer is working now. Thank you for your help! Turns out it was a driver issue. I'll describe what worked for me below in case anyone else has a similar problem.

    Problem was that I had no driver that could recognize the phone when it was on the recovery screen. Nexus Root Toolkit installs drivers for the home screen and the bootloader screen, but not the recovery screen.

    To know that this is the problem, go into command prompt and enter "adb devices". If your phone is connected and on the home screen it should list the Nexus 4 (even if the "name" is unintelligible). If you're on the bootloader screen "adb devices" should list nothing (but "fastboot devices" should list your phone). If you're on the recovery screen, "adb devices" should list your device, but for me it wasn't finding anything while the phone was on the recovery screen.

    To fix it using Nexus Root Toolkit, open it and begin the driver installation guide. Follow the instructions until step 3, and instead of the recommended option take option 4 - the custom/manual one. It will guide you through installing drivers for the home screen and the bootloader, and then you need to install one more yourself, the exact same way as the other two, but with the phone on the recovery screen (you can enter the recovery screen from the bootloader screen). You'll know it worked when using "adb devices" in command prompt lists the phone while the phone is on the recovery screen.

    Hope that saves someone an hour or three.

  • @techisfun Going to remember that. Glad your sorted. Enjoy

Log in to reply