bq Aquaris E5 HD Ubuntu Edition wants to be OEM unlocked during installation

  • @Lakotaubp The device is listed by

    adb devices

    (yes, I authorized the device by accepting the popup) and after

    adb reboot bootloader

    it is also listed when executing

    fastboot devices

    but the subsequent command

    sudo fastboot oem unlock

    starts, prints some whitespaces and then does nothing.

  • @Tartaros Now please try the installer again, after rebooting your phone.

  • @Lakotaubp The installer still says that the bootloader needs to be unlocked. I think the unlock command didn't work (it didn't even terminate).

  • @Tartaros which version of the installer are you using is it still 0.1.21 If it is please try 0,2.1, .2 or .3 they will unlock a locked bootloader. Then see what happens.
    If you still have an issue after that then I'm a bit stumped if the bootloader is still locked or registering as such. All i can think of is reflashing the canonical UT from BQ to see if that fixes it.

    Edit: Unless your suspicions are correct and the phone had an issue when returned from Bq, especially if it was not your original device. Though not sure why it would be. Unless they flashed a stock item.

  • @Lakotaubp I'm using the latest version (0.2.25-Beta), as stated above, it works when setting the phone to fastboot mode prior to launching the installer. I'm not sure whether I want to reflash the original UT image with proprietary tools, maybe I will contact bq regarding that issue and see if they can help me with unlocking the bootloader.

    I'm pretty sure that the device they sent back to me was a new one as the WiFi and Bluetooth MAC adresses didn't match the ones of the device I sent to them initially. It really seems like they flashed a stock item and locked the bootloader afterwards, maybe with a newer firmware or bootloader version that is not unlockable in the same way as the original devices.

  • @Tartaros Must be worth getting in touch. One last thing would be to try a live usb stick with Ubuntu 15.04 on it to run the installer.

  • Hi,

    I got the exact same issue like @Tartaros , with my BQ e4.5.
    I am on Manjaro too. But I have flashed ubports with it before...

    I also flashed the original old android, then flashed old canonical image and tried again, with exact same result.

    But now as I write, I remember that I got this "oem locked" message for FP2 too, which is already on latest ubports RC.

    So it seems to be definitly an issue with Manjaro... or the fastboot package of Manjaro...

  • Okay.
    I can confirm that the problem is the android-tools package of manjaro-community package.
    I uninstalled it, and installed the android-sdk-platform-tools AUR-package.

    Now it works, although I am not shure, if the installer is using the AUR package or if it is using it's own tools?!

  • @Luksus Thank you for the info! As soon as I find time to, I will try this too!

  • @Tartaros said in bq Aquaris E5 HD Ubuntu Edition wants to be OEM unlocked during installation:

    @Lakotaubp I expect I need to switch the device to fastboot mode prior to performing the OEM unlock? I will try it tomorrow.

    In theory yes, snaps can be run with Manjaro, but the snap support is still experimental and I do not want a snap error to make my phone a pricy paperweight.

    You can try the appimage it works well.
    I just tried today the snap installer since the aur package was giving me the same error as yours and it worked flawlessly.

Log in to reply