Nexus 5; stuck on "Waiting for device to enter recovery mode"



  • I am running this installer from Windows 10.



  • @notantenna Try putting it into recovery yourself. Hold both volume buttons and power button at the same time. When it buzzes let go of the buttons. You should see the droid on its back, use the volume buttons to select recovery then press power button.



  • It is already on the UBports recovery mode screen during this error.



  • @notantenna Use android recovery to clear the cache and factory reset it. Then rerun the installer with wipe if you can. Have you changed the partion sizes at in any previous installs



  • No, I hadn't.



  • @notantenna Good no need to mess with that then. Just do the other stuff and try again. Also try a different usb cable if you can.



  • I don't know how to return to the stock android recovery mode from UBports, but from this mode to Android actions I had cleared cache partition and data/factory reset. (I'm not tech savvy). I haven't gotten a different result.



  • @notantenna Sorry for the delay it's nearly time for me to stop for today and got distracted. No you have done what I meant. Ok a few other things to try. If your not using 15 sec adb from XDA developers use that. Remove your old version first and then install 15 sec. Try a few different ports and cables and unplugging and replugging in the usb to the device if it sticks again. Try a different installer version 0.2.7 worked ok for me.
    Also

    This is a typical error. There are variables according to your local situation. The link below is the solution that worked for me. Others report success with trying SEVERAL different USB cables, unplugging and replugging the USB cable when the installation is stalled, rebooting the phone while the installer is stalled, and rebooting the computer to acquire a good adb connection. Try different USB ports on your computer, preferably those on the motherboard on the rear panel. Sometimes while the phone is in UBports recovery, it needs a factory reset/wipe. Sometimes adb on the PC needs to be removed and reinstalled. Bad USB connectors on phones sometimes require the cable to be taped down to prevent shifting and losing connection during installation. If your phone has had an Android 9 custom ROM installed, it needs to have the system partition returned to original size and the most recent factory ROM reinstalled.

    https://github.com/ubports/ubports-installer/issues/593

    From our Telegram Install group . Read through and try sorry need to go good luck. Will post link to Telegram Install group in a sec if you need more help.





  • 15 sec adb installed the driver for the phone onto my computer which made this installer recognize it automatically, and then the installer moved past this stage. It's taking a long time to download and for the past few minutes hasn't moved past "Downloading file 1 of 12". I'll try these troubleshooting things, but I only have one cable.


Log in to reply