Oneplus 3/3T

  • @andybleaden said in Oneplus 3/3T:

    By way of an update I had a little bit of time again to play around with this and following the excellent help from @mateo_salta managed to get somewhere.

    A little headache with the install since the UBPorts installer had changed meant that I had to go back a step and follow the instructions right at the top

    Ie wipe phone with twrp PLUS change the file type where I could in twrp to EXT4 then reran the UBports installer and it worked again!

    The next trick involved reading instructions a little clearly as to try to install the Openstore click using the first link we had did not work (it was not for 64bit!) so using @mateo_salta google drive I managed to download it then install via the terminal using the pkcon instruction above.


    Open store Downloaded and installed as well as UT Tweak
    Screenshot from 2019-12-08 14-25-12.png

    Now to add some functionality as I note I still need some more apps.

    Camera I can confirm does not take pictures on my device (yet) but it does open and switch cameras

    Lots to do and cant wait to get cracking again on this.

    Smaller update. I note a few things:

    Updates via Open store dont seem to want to work even though the system is writeable and also the device is not picked up when plugged into a laptop.

    All fixable I am sure.

    In the meantime I have got lots more apps installed and noticed all my older apps are not working even though they installed via the Openstore ...thats for later!


    Strange it is the web apps with ogra containers that dont work

  • @paci87 nice work, will this overwrite the "your device is unlocked" screen as well?

  • @dieharddan thanks! No, that should be pure text based.
    I used this one. Additionally the battery low and fastboot splash screens can be edited.

  • Can anyone shed any light on whats happening with updates on my OP3T?

    In System Settings there are 2 updates available both of which will not install. One is the Terminal app and that has been showing since installation of the OS. More recently an update for OpenStore has shown up; also fails to install. I wonder if these are armhf updates?

    But there is also an ubuntu touch Version 44 update that has downloaded but does not install. This one appeared after I checked the update settings. The channel is still edge, but when taking a look in the channel settings there are two edge channels in the list. Is this how it should be, does anyone know?

  • @ziggutas I have the same with the app updates and you can't swipe right and delete them. The system update you can swipe right and delete I think. I'm guessing the update system is a little flawed at the moment and you can add fluffychat to the list now.
    As for the channels, one is going to be the normal edge channel available to everybody and should not be used on a DD at all. The second is again not 100% on this the arm64 version of edge for OP3/T as there is no dev, RC and stable for that.

  • Same issues for me. I went ahead and performed the update via the installer

  • @Lakotaubp OK, thanks. I best leave the channel settings as they are...there is no way to distinguish between the two 'edg' entries.

  • I can't connect to my phone with adb, only in recovery mode. I ran out of ideas. Does it work for any of you?

  • adb isn't functioning for me either, but ssh does with manual start:

    Faulty updates:
    Terminal - I have self-compiled the latest versions from gitlab, and then those updates go away.

  • In any Halium port (Sony X, OP3, OP3T) there is no ADB enabled by default. Instead you can use ssh, which provides us with a common method for Android and Non-Android devices in the future.

  • @Flohack Thanks for the clarification. How can I install apps to anbox without adb?

  • @paci87 You are mislead by the container architecture:

    • First you need a way to access Ubuntu Touch (adb OR ssh)
    • Then you install adb inside UT
    • Then you can use it to access Anbox or install apks there

    Its like an onion 😉

  • @Flohack I did get mislead. I made it work, thanks to you!

  • Unfortunately the current update for the OP3T also failed. What is the procedure here? Will there be working updates in the future? Or does UT need to be installed again via the UB-installer?

    What happens with private data, contacts, sms, settings or already installed apps when UT will be installed again via UT-installer?


  • @ma My recollection is that reinstalling via UBports does NOT wipe data

  • @ma My OP3T just installed 'Version49' ok.
    Edit:Not sure where I got this idea from, I thought it was a post in this thread, but on reflection I think it may not have any effect on the updates installing or not. Installed Version 50 with one touch this morning without uninstalling UTTT.Next time a system update sticks I will try Lakotaubp's method (see below). It seems a bit more logical!

    When using the installer there is a checkbox to select wiping data if one wants to do that. Make sure it is blank/unchecked if you want to save your settings etc! By default it is unchecked, no wipe.

  • Version 49? I received version 48.

    I uninstalled the tweak tool. But the system does not respond to pressing the installation button. Maybe I have to wait until the next update.

  • @ma If mine sticks, I go through to the update channels then back again and the update is downloading. Also I would reinstall UT Tweak Tool.

  • Happy to see the notification led working now!

  • @ma Apologies, I may have given you useless advice! I have edited my previous reply to your question.

    Hope you have managed to get the latest updates following Lakotaubp's method.

Log in to reply