nexus 4 - transfer files?



  • recently, a friend of mine gave me his nexus 4 16gb as a present.

    yesterday, i have installed latest stable version of ubuntu touch via ubports installer without problems.

    now the bad news is, the device does not offer a sdcard slot, and i am struggeling to transfer files from/to it.

    is this possible via usb connection at all (under arch linux)?



  • Hi, @utouchuser
    You can activate SSH connection via UT Tweak Tool (from the Open Store)
    Then you can send files through SSH.

    At home I also use the app "Bluetooth File Transfer" which allows me to exchange files with my computer via BT.
    Didn't try it for some now and wonder if it's still working though 🤔

    Oh and of course you can share data through USB by mounting your device in MTP. It should appear in your desktop when plugging the USB cord. Just check that your cable is OK.



  • @AppLee said in nexus 4 - transfer files?:

    Oh and of course you can share data through USB by mounting your device in MTP. It should appear in your desktop when plugging the USB cord. Just check that your cable is OK.

    this is actually what i try to achieve 😉

    unfortunately, when connecting via usb and selecting the nexus 4 device, i get this error message in dolphin:

    no memory media found. check, if device is unlocked and if mtp mode is activated in usb trasnfer options.

    am i missing something special here?



  • @utouchuser Hum I don't remember doing anything special.
    Make sure to unlock your screen so the desktop can access the filesystem but I don't think it's your problem...



  • The tweak app has an option to enable/disable MTP. Maybe try that.

    But often it is just a cable issue, try another one 😉



  • @poVoq
    Hum right.
    Which makes me thinks that it's linked to the developer mode ; but not sure if it has impact 🤔



  • screen is in unlocked state.

    i dont think it is a cable issue (only have this one atm), installed ubuntu touch with the help of it, should be fine.

    so mtp options is only avaiable via tweak app? going to try this next.

    perhaps it is a dolphin/kde setting i should be looking for? mtpfs, gvs-mtp, libmtp and a few others are installed by default.



  • ok issue solved.

    i had not setup any password nor pin for testing purposes.

    now that all of this is true, the nexus is perfectly recognized as an mtp device.

    thank you all for the tips.



  • @utouchuser Glad you solved it !


Log in to reply