[SOLVED] - Nexus 4 - impossible to install UT via the UBports installer tool

  • Hi Everybody,

    First, I've installed UBports installer (0.4.6-beta) on my computer (Ubuntu 16.04.1 - x86_64 - 4.15.0-66-generic).

    On the phone I've applied the "developper mode" and enabled the "USB debugging" (I didn't find any "OEM unlock" option).

    Then, as it is showned in the video demo :

    • I launch the installer on the computer ;
    • I connect the phone
    • I click on the "Select device manually" button ;
    • I choose the channel (16.04/stable) and checked the "Wipe personnal data" box (the "Bootstrap" box is already checked) ;
    • the reboot begin then it stays blocked on "Flashing firmware...). And the phone stays on fastboot mode (see the attached picture) => http://free-pictures-hosting.org/upload/2019-11-06-15-53-41-479952-fastboot-nexus4.JPG

    Please, can you help me to solve this trouble ?
    Many thanks,

  • @lool_lauris you need to unlock your phone first.

    sudo fastboot oem unlock

    From a terminal should do it with you r phone as the picture

  • I've done it trhough adb. I had a dialog box to unlock but it syill does not work.

    So I've tried the manual installation. I have done (in "sudo mode" because it does not work without) :

    • sudo fastboot oem unlock
    • sudo fastboot format cache
    • sudo fastboot reboot-bootloader
    • sudo fastboot format userdata
    • sudo fastboot format system
    • fastboot flash recovery recovery.img

    But now, I'm stuck with this instruction :
    "Create a new text file with LF line-feeds called "commandfile" with the following content:

    format system
    load_keyring image-master.tar.xz image-master.tar.xz.asc
    load_keyring image-signing.tar.xz image-signing.tar.xz.asc
    mount system
    update ubports-a1f443971032f2b6a03ed6f83d3340e026d59bfbe1625b259fb77eb05fa2b6a9.tar.xz ubports-a1f443971032f2b6a03ed6f83d3340e026d59bfbe1625b259fb77eb05fa2b6a9.tar.xz.asc
    update device-72a91d077d15b973052cfff546d7d0a94b8bf38376c7a688a8e0754c1a468aca.tar.xz device-72a91d077d15b973052cfff546d7d0a94b8bf38376c7a688a8e0754c1a468aca.tar.xz.asc
    update keyring-4c4e7ef380ebcfa2c31084efa199138e93bfed8fc58aa3eb06bdf75a78af9b57.tar.xz keyring-4c4e7ef380ebcfa2c31084efa199138e93bfed8fc58aa3eb06bdf75a78af9b57.tar.xz.asc
    update version-9.tar.xz version-9.tar.xz.asc
    unmount system

    I have stored the file "commandfile" in the current directory /tmp/ubuntutouchinstall.

    The device is not found. I

    I am really completely blocked !

  • Just to make sure: you rebooted to recovery, right? Does it show the UT recovery on the phone?
    And it's this command that fails? With or without sudo?

    adb shell "mount -a"

    Can you post the output of

    adb devices

  • Hi Ingo

    Many thanks for your reply. Please, excuse my very late reply, I was out very late during all that day.

    As described in the Nexus4 manual installation instructions ( https://devices.ubuntu-touch.io/device/mako ), I was stuck just after the comand line :

    fastboot flash recovery recovery.img

    As you asked, here after the output of : adb devices

    laurent@lool-W510:/tmp/ubuntutouchinstall$ sudo adb devices
    List of devices attached
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *

    I think I have lost the previous system (Android). But If you see the following pictures, there is some options in the Recovery mode :

    With the following command :

    laurent@lool-W510:~$ lsusb
    Bus 003 Device 111: ID 18d1:4ee0 Google Inc. 

    I have find the idvendor => 18d1

    So, see the output of

    laurent@lool-W510:~$ lsusb -v -d 18d1:
    Bus 003 Device 111: ID 18d1:4ee0 Google Inc. 
    Device Descriptor:
      bLength                18
      bDescriptorType         1
      bcdUSB               2.00
      bDeviceClass            0 (Defined at Interface level)
      bDeviceSubClass         0 
      bDeviceProtocol         0 
      bMaxPacketSize0        64
      idVendor           0x18d1 Google Inc.
      idProduct          0x4ee0 
      bcdDevice            1.00
      iManufacturer           1 Google
      iProduct                2 Android
      iSerial                 3 019108625c571041
      bNumConfigurations      1
      Configuration Descriptor:
        bLength                 9
        bDescriptorType         2
        wTotalLength           32
        bNumInterfaces          1
        bConfigurationValue     1
        iConfiguration          0 
        bmAttributes         0x80
          (Bus Powered)
        MaxPower              500mA
        Interface Descriptor:
          bLength                 9
          bDescriptorType         4
          bInterfaceNumber        0
          bAlternateSetting       0
          bNumEndpoints           2
          bInterfaceClass       255 Vendor Specific Class
          bInterfaceSubClass     66 
          bInterfaceProtocol      3 
          iInterface              4 fastboot
          Endpoint Descriptor:
            bLength                 7
            bDescriptorType         5
            bEndpointAddress     0x81  EP 1 IN
            bmAttributes            2
              Transfer Type            Bulk
              Synch Type               None
              Usage Type               Data
            wMaxPacketSize     0x0200  1x 512 bytes
            bInterval               0
          Endpoint Descriptor:
            bLength                 7
            bDescriptorType         5
            bEndpointAddress     0x01  EP 1 OUT
            bmAttributes            2
              Transfer Type            Bulk
              Synch Type               None
              Usage Type               Data
            wMaxPacketSize     0x0200  1x 512 bytes
            bInterval               1
    Device Status:     0x0000
      (Bus Powered)

    Do you think that it would be possible to install UT with the options actually in the recovery mode ? => http://free-pictures-hosting.org/upload/2019-11-07-23-42-17-699564-fastboot-nexus4-4.JPG

  • I'm a little confused by your screenshots. The first shows the android recovery, the next ones the UT recovery.

    The output of "sudo adb devices" you posted, was the phone in the UT recovery at that time?
    The output does look like either the phone was in the wrong mode or the USB connection is bad (aka. broken cable/port).

    Maybe someone with a Nexus 4 has some idea what's missing.

  • Hi Ingo,

    After many tries, I've reached to install UT !

    To do it, I was obliged to set the phone on the UBports recovery mode. Then to verify by lsusb that the phone was recognized (see this - sorry it's in french => http://debian-facile.org/doc:materiel:reconnaitre-peripherique-android ).
    And begin again the installation from the pushing step of each files previously donwloaded.

    Many thanks for your help.

  • Glad it worked out in the end ☺

Log in to reply