uNav GPS not working



  • Hello forum,

    I recently got an oneplus one and installed ubports. Its amazing but I'm still leaning a lot.
    I already searched the forum but did not find a matching solution for my situation.

    Google Maps webapps show me the correct GPS position but using uNav and hitting the "show my gps position" button always plots me a totally different position on the world map. It jumps from finnland to austria.

    phablet@ubuntu-phablet:~$ ps aux | grep [l]ocation-service | grep provider
    root       932  0.0  0.3 108892  9876 ?        Ssl  09:55   0:03 /usr/bin/ubuntu-location-serviced --bus system --pro
    vider gps::Provider --provider remote::Provider
    
    

    Any idea what I could try?

    Greetings,
    JimmyPesto



  • Try Pure Maps, uNav is showing it's age.



  • @Giiba
    it should not be related to the app itself as they are relaying on the same background.

    Does Unav as permission to get location ? is the location icon getting full white ?



  • Then why does one app show the right spot and another doesn't? It's certainly over my head why, but trying the better app cannot hurt... as I wouldn't rule out that Google is doing the Google thing despite the background info being wrong.



  • If I remember correctly the first tine it's used it can take 20 mins to get the first position correct. You need to be on wifi preferable keep the screen on via battery setting and leave it to do it's stuff. After that uttered should be OK.



  • Wow awesome, big thanks for your quick feedback!

    Today is the second day I was using Ubports and suddenly uNav worked like a charm. The only thing I was missing is a voice telling me where to drive. Even though I tested selecting English and German speech in settings.

    @Giiba I did try Pure Maps but it does not support point to point navigation, or does it? I really need a reliable navigation app for my car.

    @ernest yes location access was permitted. I don't know about the whiteness of the icon sry.

    @Lakotaubp I guess this was the problem, I've tested it at the window of my apartment with WiFi on, an while being outside yesterday, but maybe little bit to short as I also switched between apps.

    Again thanks for your support guys. This is just awesome, I love it having a Linux OS on my Smartphone without paying hundreds of bucks for a Purism.



  • @JimmyPesto
    Pure maps does support navigation though the voice is known to not work. Voice in uNav should work...



  • @JimmyPesto
    to increase the reliability before each journey a reboot of the phone helps a lot.



  • @Giiba Thanks for the advice. At the moment in Pure maps I do not get search results for huge German citys. I dont know why. Its based on Mapbox for the moment, should I change this?

    @ernest I will try this. Thanks.



  • @JimmyPesto In my experience, search with uNav lack flexibility.
    If your input is correct and how the system expect it then it's fine. PureMaps is easier to use on this aspect and the suggestions are quite fast (or I'm a slow writer).

    I use PureMaps but I never use the voice guidance. I hate when someone give me orders ^^



  • @AppLee Pure Maps does not give me any suggestions at the moment sadly. It neither finds any German city at all. I don't know whats wrong with it. Even tough I can zoom into cities and streets successfully.



  • @JimmyPesto Have you searched for UK, Belgian or French cities ?
    I'd like to know if your problem is specific to you or about Germany (which I don't think it is) and maybe you can try with english name of those cities Berlin and Paris are easy because it's the same in most languages (latin based)...



  • Honestly, I find search poor in both apps. Generally I need to manually find the location and then get directions to a pin on the map, for either to work. Both seem too simple, in that if you don't enter the address exactly as it is in the database (1234 E Broadway vs 1234 Broadway E) you get no results or ones from cities around the globe. Lol, I am in Vancouver and I am not driving to Europe today.



  • I use Photon as search engine.
    And it worked fine until a test I just did...

    So I guess there could be a problem with Photon right now... OpenCage is working so not an issue on PureMaps, but probably on Photon.

    BR



  • Thanks for your support. It has been a while and I still enjoy my UBports phone.
    BUT the main problem still remains with the slow GPS. If im on the go and need some directions I cant wait for 10 minutes and/or reboot the phone until it works. This is a great practice to keep calme though.
    Searching streets in Germany works better now. I switched the maps once but I cant tell whats selected right now. It only says "Mapbox (Voreinstellung)" in maps settings menu. But I cant tell if it is selected.
    @AppLee how can I see the selected search engine?
    I just bought an OnePlus 3T, will the GPS be as slow as with my OP One using UBports?
    Greetings.



  • @JimmyPesto
    GPS is not slow, it's normal.
    Lack of A-GPS is what you consider being slow.

    Do not reboot your phone it doesn't help.
    The first fix takes a long time, but then it's faster (if you don't reboot).

    In pure maps:

    • Tap the magnifying glass icon
    • Then tap the mini hamburger menu in the top right corner
    • It shows the selected search engine

    If you tap on it you'll see more info: default is set to photon for me and there are alternatives (Digitransit and OpenCage)

    Mapbox is the default tiles used for the map ; not the search engine



  • @JimmyPesto Last time I tried on OP3 with uNav it took about 20 secs. Today uNav is blank for me so can't check just now



  • @AppLee Yea you right, first localization is slow. After this GPS is okay.
    What exactly do you mean by "first fix". So after each reboot or power on the phone has to relocate itself for the first time? What about turning GPS off/on in the settings?
    Thanks for clarification, I'm using Photon as well, and its suggestions are reasonable.

    @Lakotaubp with GPS always enabled and the phone was powered on for some time I guess? 20s sounds great.



  • @JimmyPesto
    What we call GPS fix is the time for a GPS chip to catch enough GPS satellite signals to determine its location.
    The first fix is the first time your phone is able to localize itself.

    In fact I don't know if turning off the GPS using the settings will have the same effect as turning off the phone ; maybe.
    I rarely turn it off because it doesn't use so much power...



  • I'm used to this from using Android. It gives you the feeling of having control of your data. haha
    Maybe I should just keep it enabled all the time.
    Thanks for your quick feedback. 😉


Log in to reply