Call for testing: Samsung S3 Neo (s3ve3g) owners



  • @zenfunk Ok that looks not so bad, use ssh phablet@10.15.19.82 to get inside 🙂 - I will tell you what to look for, but basically use dmesg and /system/bin/logcat to get an idea whats going on. The phone has booted but is not able to get into graphics mode, we will find out why.



  • chris@funkbook:~/Downloads/s3neo/halium-install-continuous$ ssh phablet@10.15.19.82
    ssh: connect to host 10.15.19.82 port 22: Network is unreachable
    

    not good...



  • @zenfunk Then please hold VOl-Up, Press power until you get the blue text for recovery. Then, in recovery, use cat /proc/last_kmsg to see what goes wrong there...



  • https://pastebin.com/pNmtTZ9z

    this is last_kmsg



  • @zenfunk Ok I will compare with my device. Can you please also send me a getprop output from recovery? Thx





  • @zenfunk Hmm what OS was installed before? Would you mind trying to reset to Android 5.1? It might have some effect, because otherwise I am not sure whats going on ^^



  • it was lineage 7.1.
    I just reformated /data to ext3, but no improvement.
    There are two different kinds of s3 neos around. One with Sony and one with a Samsung camera module. May this be it (not sure which one I have. Will reflash android 5.1 (which one did you use) and then we'll see.
    Thank you very much for your time and efforts,
    Chris



  • @zenfunk Hmm the camera should not block the UI to start, actually. Very weird also that you do not get ssh connection. Did you specify -p ut parameter when installing?



  • Actually I didn't use -p ut because the script then exits.

    ./halium-install -p ut ubports-touch.rootfs-xenial-armhf.tar.gz system.img
    usage: ./halium-install rootfs.tar[.gz] system.img [release]
    
    positional arguments:
        rootfs.tar[.gz]
        system.img
    
    optional arguments:
        release: run common post installation tasks for release.
                 supported: none, halium, pm, ut
                 defaults : none
    


  • ./halium-install ubports-touch.rootfs-xenial-armhf.tar.gz system.img ut
    

    works, I'm trying to boot as we speak. I keep you posted.



  • Well, with the above command I got to pick a unix password, but still hangs at the boot screen.



  • @zenfunk Hmm seems to be the wrong halium-install, how did you get it? The right one has the parameter -p ut as first argument.



  • I got it from there: https://gitlab.com/JBBgameich/halium-install/-/releases
    I downloaded the zip file, unzipped everything, put the imagefiles in the folder as well and ran the script.



  • @zenfunk Ohhh thats very old! The continous release is not working anymore it seems. Can you please try to clone the code instead directly? Have you got experience with git?



  • Funny, I just did this.
    The -p ut option works now. dmesg output is:

    [ 9620.086869] usb 2-1.2: new high-speed USB device number 20 using ehci-pci
    [ 9620.200193] usb 2-1.2: New USB device found, idVendor=18d1, idProduct=d001, bcdDevice= 2.28
    [ 9620.200199] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [ 9620.200203] usb 2-1.2: Product: SAMSUNG_Android
    [ 9620.200206] usb 2-1.2: Manufacturer: SAMSUNG
    [ 9620.200210] usb 2-1.2: SerialNumber: Halium initrd Debug telnet on port 23 on rndis0 192.168.2.15 - also running udhcpd
    [ 9620.207225] rndis_host 2-1.2:1.0 eth0: register 'rndis_host' at usb-0000:00:1d.0-1.2, RNDIS device, 00:00:00:00:00:00
    [ 9620.250120] rndis_host 2-1.2:1.0 enp0s29u1u2: renamed from eth0
    chris@funkbook:~$ ssh phablet@192.168.2.15
    ssh: connect to host 192.168.2.15 port 22: Network is unreachable
    

    On reboots I don't even get the RNDIS device.

    Will start over...



  • I tried again with an 5.1 Android, used the cloned installer, used your heimdall, and now I don't even get to the ubuntu boot screen.

    No clue what to do next.



  • @zenfunk said in Call for testing: Samsung S3 Neo (s3ve3g) owners:

    used the cloned installer, used your heimdall, and now I don't even get to the ubuntu boot screen.

    Hmm sounds weird. what does dmesg say



  • [14506.583270] usb 2-1.2: new high-speed USB device number 41 using ehci-pci
    [14506.691529] usb 2-1.2: no configurations
    [14506.691542] usb 2-1.2: can't read configurations, error -22
    [14506.779122] usb 2-1.2: new high-speed USB device number 42 using ehci-pci
    [14507.079205] usb 2-1.2: device descriptor read/64, error -71
    [14507.297126] usb 2-1.2: New USB device found, idVendor=18d1, idProduct=d001, bcdDevice= 2.28
    [14507.297133] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
    [14507.297137] usb 2-1.2: Product: SAMSUNG_Android
    [14507.297140] usb 2-1.2: Manufacturer: SAMSUNG
    [14507.297143] usb 2-1.2: SerialNumber: halium-initrd
    [14507.301658] rndis_host 2-1.2:1.0 eth0: register 'rndis_host' at usb-0000:00:1d.0-1.2, RNDIS device, 00:00:00:00:00:00
    [14507.362236] rndis_host 2-1.2:1.0 enp0s29u1u2: renamed from eth0
    


  • @zenfunk Looks like now we are kinda stuck with the init. Can you send me again cmdline you used for halium-install?


Log in to reply