Calendar App Sync issue with Google Calendar



  • Hi Everyone,

    I was able to get most of my calendars from google calendar synced up with the ubp calendar app. Most of them showed up, but some did not. For instance, the calendars that show up under "My Calendars" in google do not appear on the ubp calendar app. I'm not sure what the difference is exactly because I have calendars under "My Calendars" and "Other Calendars" in google. Any thoughts on how to get all calendars in google to shop up on the ubp app?



  • Mhmm... no clue. So they are not listed on the calendars page? (Second right icon in the top right corner.)



  • Well, it's a bit strange because some of the do. Let me see if I can elaborate this a bit more.

    If I sign into my gcal account on a desktop, on the left under "My calendars" I see 4 calendars:

    1. My own (called Alex)
    2. Colorado Rockies
    3. Colorado Avalanche
    4. Denver Nuggets (I like Colorado sports, hahaha).
    5. Contacts

    Under "My calendars", there is another section called "Other calendars" which has:
    A) Holidays in the United States
    B ) Alex's FB Events
    C) International Rugby

    When I sign into the ubpCal app and look on the calendars page, I see:
    a) My own (called Alex)
    b) Contacts
    c) Holidays in the United States

    So for some reason, calendars 2, 3, 4, B, and C do not show up in the ubpCal app. My naive guess is that how I subscribed to the individual calendars on my gcal affects if their synced or not in ubpCal. I hope that helps clarify the issue. Maybe I could take a look at how A was subscribed to and see if the same subscription method words for, say, 2?



  • Any further thoughts on this issue?



  • Do you have an android phone around, just to see whether these calendars are synced to an average calendar app...? 😬



  • I do have an android phone. I checked the Google Calendar app on the Android and those calendars are there.



  • These calendars you don't see. Some of them can be subscribed by anyone right? Do you have links?



  • @hummlbach That's a good point. I'm trying to get to the bottom of how I subscribed to them originally. Whether I found them through the google calendar app or by some other means. I'll update here once I figure it out.



  • Here's something interesting that happened...

    I went into my google calendar on a laptop, removed the Colorado Rockies calendar, and re-subscribed to it in two different ways:

    1. By using the method that is built into google calendar. Namely, Settings -> Add Calendar -> Browse calendars of interest.
    2. Through the MLB website.

    I then went into my ubp phone and removed my previous Google account from the list of accounts in the Settings of ut. Removed and reinstalled the ut Calendar app, launched it, went to add my Google calendar, entered in my google credentials, and got the following error:

    "Sign in with Google temporarily disabled for this app.
    This app has not been verified yet by Google in order to use Google Sign In."

    I thought that was pretty weird since I didn't get an error like that last time. I checked my email and there was no notification about trying to sign in from a different device.

    I restarted my ut phone and tried again. Got the same error.
    I removed the Calendar app, reinstalled it, and tried again. Got the same error.
    I tried to add the account through the Settings app of ut and got the same error.

    Anyone run into this before?



  • @aclifton314 What channel are you on. I had this with a OPO on Dev or edge and went to stable signed in then went back to whatever. Also you need to have insecure apps selected in your Google account settings.



  • @Lakotaubp I am on the stable channel. I'll turn on insecure apps in my Google account settings and report back if that fixes things.



  • @Lakotaubp I turned on the insecure apps option for my google account settings (Settings -> Security -> Less secure app access on) and tried to sign in from my ut device and still got the same error. It also looks like my ut device showed up under "Your Devices."

    I signed out of my account on every device listed (except my laptop) and tried again but got the same error. Maybe it takes some time for the new settings to take affect?



  • @aclifton314 No should work straight away. I only have my OP3 on hand at present and that doesn't have Google account on it so trying to remember my OP1 settings.
    Thats on dev and all Google accounts worked on that last time I checked. So maybe, and I know it's a pain to keep trying but, delete your Google account in System Settings, change to dev channel and install update. Then add back in your Google account in System settings you will know straight away if it works. Then switch on calendar and contact sync in account settings.



  • @Lakotaubp Here's what I did:

    • Changed to dev channel and installed update.
    • Went to System Settings and tried to add Google Account. I got "Couldn't sign you in. This browser or app may not be secure. Try using a different browser."
    • Confirmer Google account settings that Less Secure App Access is turned on.
    • Launched Calendar app on OPO.
    • Tried to add online calendar, but received the same error as above.


  • @aclifton314 Not sure now. I now that some issues might be coming see here https://ubports.com/blog/ubports-blog-1/post/ubuntu-touch-q-a-68-262 but mine appear to still be working. Also after adding the account (which admittedly you can't) and allowing access in Account Settings my google calendar and contacts are there I don't have to add them. Let me double check and see if mine are still working.



  • @aclifton314 Just tested mine. Deleted one account and tried to sign back in and got same message as you. Kept trying and getting same then got one of those enter the text you see below boxes. Filled that in then all went ok with login and phone verification. Going to check sync now.

    Edit: Took about 8 attempts to get the sign in text thing



  • @Lakotaubp Ahh that's interesting. I went to the ubuntu touch GitHub and looked for open and closed issues related to "calendar" and it appears that there was a bug that seems similar to what we have documented here. Here is what I have tried:

    • Switched to the stable channel and installed update.
    • Tried to add google account in Accounts. Received the "Temporarily disabled for this app" error.
    • Did 10 attempts at adding google account. All failed.
      • I noticed that the heading text of the Google Account sign in was "Ubuntu.com".
    • Switched to Release candidate channel, installed update, and repeated attempts at adding google account.
      • I got "Couldn't sign you in. This browser or app may not be secure. Try using a different browser." the first attempt.
      • I noticed that the heading text of the Google Account sign in was "UBports.com".
      • On the 2nd attempt, I got the captcha word thing and was able to add the account.
      • I was able to sync my contacts and various calendars on this channel. I should note, that the calendars had to appear on my Google Calendar as "checked" in the list on the left hand side during the initial sync. Once they all synced, it didn't matter if they were checked on the google side or not.

    I didn't try the Dev channel at all, but it seems to be working on the release candidate channel. Not sure if this discrepancy is worth reporting to the ubuntu touch GitHub?



  • @aclifton314 Good your in then. Couldn't remember it's called captcha last night



  • Thanks @Lakotaubp and @aclifton314 . I had the same issue, but after trying a few times it let me continue to a captcha and was able to add my account.


Log in to reply