Bluetooth refuse to be activated on Nexus 5



  • Bluetooth refuse to be activated

    Device: Nexus 5
    Channnel: Devel (2020-02-17)

    Switch On device does not keep on.
    No device detected

    What is the command to manually turn on Bluetooth
    BluetoothIndicator
    http://paste.ubuntu.com/p/bF8VdQYnrD/
    dbus:
    https://paste.ubuntu.com/p/nhpbzfNSzf/



  • You might want to find an Ubuntu admin on IRC and get that dbus paste removed, as it contains your phone number.

    Beyond that, you can check what rfkill says. Also, have you had the power button replaced (as this is a common issue on Nexus 5, and can result in Bluetooth/WiFi being damaged if not done correctly)?



  • Same issue on N5 with recent update on rc channel...



  • @dobey thanks for your attention



  • For me too on N5 latest rc. A full wipe and reinstall solved the problem.



  • @dobey:

    rfkill list
    0: phy0:Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: brcmfmac-wifi: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    

    rfkill event return nothing when trying to turn on Bluetooth



  • Interestingly I have the same issue on the Halium-7.1 port for hammerhead, which is far from being ready, but it was heavily based on the 5.1 version. I will take a look if smth has been changed lately.



  • I installed RC channel and Bluetooth is back



  • I reinstall devel channel and Bluetooth is working, I could connect a speaker, unfortunately the Jabra device I need to use is not visible.

    0: phy0: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no
    1: brcmfmac-wifi: Wireless LAN
    	Soft blocked: no
    	Hard blocked: no
    2: hci0: Bluetooth
    	Soft blocked: no
    	Hard blocked: no
    

    Connecting to my Bluetooth speaker works but as the device allow to use it as remote command for selfie, it is discover as keyboard and so I'm not any more able to use phone virtual keyboard. Is there a way to force using the device as just an external speaker ? Or is there a way to use the phone virtual keyboard as well if an external keyboard is detected ?



  • @saveurlinux said in Bluetooth refuse to be activated on Nexus 5:

    Connecting to my Bluetooth speaker works but as the device allow to use it as remote command for selfie, it is discover as keyboard and so I'm not any more able to use phone virtual keyboard. Is there a way to force using the device as just an external speaker ?

    You could try bluetoothctl. It's the command-line interface for bluetoothd. When you type(*) that command in a terminal, you get an interactive session. Try the commands scan, list, devices to see which devices there are. There should be at least one: the controller itself. Here's a nice intro (in German, but the commands are in English, anyway):
    https://kofler.info/bluetooth-konfiguration-im-terminal-mit-bluetoothctl/

    (*) OTG cable and USB keyboard works fine for me.

    Maybe your speaker shows up as 2 devices, so you could disable one.



  • I was also affected by this issue after updating to version 66 today.
    Reinstalling via the UBports Installer resolved the issue.

    Install options used:
    Channel: 16.04/rc
    Wipe Userdata: No
    Bootstrap: Yes
    Format system partitions: No


Log in to reply