App menu double entries w/Anbox

  • Is it just me or are others seeing double entries in the app menu after installing Anbox? I'm on Dev channel Nexus 5.

    Ideas on how to fix it? I've searched the forums and can't find anyone having this issue.

  • Can you be more specific about what is duplicated? Is it only the few apps which also come in AOSP such as clock/calculator/settings?

  • screenshot20200311_214956193.png

  • Tell me how I can post a picture and I'll show you. But, basically, it's like the post above ^^^

    Just Android apps are being repeated, not UT System apps. Most have stopped at two copies, but some seem to add or reduce randomly. FDroid had three copies, and now only has one, everything else has two currently. I tried resetting just the launcher but that didn't do anything. I erased and re-installed the whole UT system image and re-installed Anbox and it happened again. So it wasn't because I goofed something on the first install. I followed the UBPorts guide without installing the kernel as the UBPorts Anbox forum instructs.

  • @dobey Yes, it includes AOSP calendar, clock, settings, calculator, contacts, gallery, and every Android app I've installed.

  • OK. Not sure what would cause that. Seems like some bug is causing the launcher files to get duplicated many times. Does the number of repetitions perhaps match the number of times each app has been updated inside anbox?

  • The duplication occurs when you open an app that crashes. I now have three FDroid apps. Some Android apps function as expected, but some do not. The ones that crash seem to interact with UT system in some way - accessing sound, files, camera, etc. Yes, I know camera is not functioning with Android.

    Funny thing is, the apps that multiply after an app crashes are not the app that just crashed, but just some random app or all apps. I have not opened FDroid at any time today. And I now have three copies of every Android app.

  • I have had that and it disappears after restart. Does it for you too?

  • @chrisse No. Mine persist after reboot

  • My duplicates disappear after each restart. I need to say that I frequently disable and re-enable anbox (I disable it so that it would not use baterry because of whatsapp) - could it be connected?

  • @mihael I don't disable Anbox. I'll try that. Disabling and restarting Anbox on each boot I think would be a bug.

    I don't have this behavior on my X86 tablet running Ubuntu Gnome with Anbox. So I'm thinking this is a UbPorts bug. Not sure which team I should file this with.

  • Well, disabling and restarting anbox clears the double entries, but they return after an app crashes

  • Hi!

    They appear, too, when Anbox is disabled, and then enabled again.
    There are two places where the icons and .desktop-files are stored , the first is /home/phablet/.local/share/applications/, the second the subdirectory .../anbox within that path.
    I tried to remove the anbox directory /home/phablet/.local/share/applications/anbox/, but it reappeared; then I changed the rights on it, so it can't be used anymore, but the entries still tend to reappear twice, thrice, etc. in the app drawer. Restarting unity8 helps a bit..

  • @hankschwie I noticed this as well, I can delete the .png files and the icons go to a single instance after a reboot, but goes back to double after a couple minutes, could just be an issue with anbox honestly, and since anbox isnt actively developed for UT (unless Im mistaken) I dont think that will change

  • @tigerpro There is a port (really a script) specifically for UT that enables Google play store and services - available on GitHub/Anbox. I've been meaning to try it out after I figure out this problem.

    Hence my confusion about who created, and who to report, this bug to. The way to install Anbox on X86 is not the same as here. On X86 you either compile from source, or download a Snap package. Here you've got the handy Anbox Tool which rather simplifies things and integrates the apps directly into your app menu. I rather like this way better. It's simpler. If I could only get those double entries to go away......

  • Try to refresh the Drawer by pulling down and releasing.

  • @c4pp4 That works and removes the duplicates, thank you! Was that working before or is it a new feature recently added? - I'm on rc channel.

  • @c4pp4 That certainly helps! But it doesn't end the problem as they randomly come back. But I'll take it until someone figures out a fix.

Log in to reply