OnePlusOne Installation stuck at Powered by Ubuntu - adb issues on 18.04

  • Hi Everyone!

    Trying to get installed on an old OnePlusOne. First used the installer (running on Ubuntu 18.04) and botched something because at some point the phone rebooted to a Factory Reset type screen (Oxygen). I tried again and the installer hung up once it tried to connect via adb (connection lost message). I tried the manual install ... but have adb issues.
    At this point, I can get to fastboot screen, all other boots/reboot/ or boot to recovery (down + power) results in the the 1+ powered by ubuntu / supported by ubports screen.
    I think the core issue is adb is not working (adb devices shows nothing). Fastboot devices shows the phone, I can issue fastboot commands (after updating the sdk tools to avoid the mk2fs error).
    I tried to fastboot flash a twrp.img with no change to anything.
    I modified udev rules as per a few posts I found - with no change.

    Any thoughts or guidance on what to try next?
    Thanks in advance!

  • @StandUpMobile First check your battery. If it charges to 90-100% then we will try something else if it sticks at 50% and still will not boot it has been a battery issue in the past. We have had a few OPO recently that have that issue.

  • Thanks! I will charge it for a while. Although in the current state, I am not sure how to show battery level!

  • @StandUpMobile Mine would always boot when connected to power but crash on disconnect but if you switch it off there should still be that topping up battery thing.

  • So, left it charging all day ... I don't get the battery meter or any led indication when plugged in ... on or off. @Lakotaubp , what was it you were thinking of trying? Thanks!

  • @StandUpMobile With my OPO switched off if it's charging and I press the power button briefly I get the charging icon with battery showing approx "fill" level so I know that's working and no indicator. If you don't get that then it looks like the battery is playing up.
    Give me a few hours to check but I'm sure when fully charged that indicator will show as full. Will let you know.
    Mean time if you can check adb is working with another phone that would help.

    EDIT: Battery Icon does fill up I would think about ordering a new battery. Easy enough to get and not to expensive.

  • Thanks @Lakotaubp . I confirmed adb working fine with my pixel3. My OPO does not show battery when I do what you suggest ... I will order a new one. However, before trying UT, it was working fine - was able to fully charge and use it. I wonder if it is the "charge screen enabled: false" causing it to not show? (See below fastboot command). I also suspect the "Device is_verified:false" maybe causing adb not to connect. I couldn't find a way to toggle that with fastboot ... do you know of a way? (I am assuming that is the android "trust device" popup once usb debugging is enabled.) During my first install attempt when Oxygen showed a factory reset screen ... I wonder if that turns off usb debugging?

    fastboot oem device-info
    (bootloader) Device tampered: false
    (bootloader) Device unlocked: true
    (bootloader) Device is_verified: false
    (bootloader) Charger screen enabled: false
    (bootloader) Display panel:
    (bootloader) console_locked: 1
    (bootloader) exec_console_unconsole: 0
    OKAY [ 0.074s]
    Finished. Total time: 0.077s

  • @StandUpMobile All I know is it goes quick when it goes without warning. Sorry but can't help with the other info. You will need someone else for that, but think your assumptions are right.

Log in to reply