• I am using a nexus 5 too.

    At 17.21 I send a message to a friend of mine with converse.js. She uses conversations.
    I see two messages in converse.js: the message I wrote and a OMEMO warning, both at the same time.

    While this is something I don't understand, I could read her answer which is shown only once with no warning.

    But it is usable so far, in fact it is the only usable xmpp client on ubports. So thank you very much for your work.


  • Messages written with converse are shown twice in converse: message (readable) and omemo warning, which tells me, that I cannot read the message, because it is not encrypted for this device. This is wrong, because the message is shown above.

    This is not a big problem, just an error message I don't understand.

    Is it possible to save the login data? I chose the automatic login at the start screen, but it saves only the bosh date, not login and password.

    Thanks, j.

  • Sorry, I never saw the double message issue. Maybe check the OMEMO keys and remove/reset them?

    Edit: maybe a message carbon issue? What xmpp server are you using? Maybe it doesn't have carbons (and mam?) enabled?

    Automatic login is working here with the 0.2.0 version. I need to double check the code to see what might be going wrong in your case. It sometimes is a bit slow, so you might see the login screen flash shortly, but then it should log in again.

  • I'm using with ejabberd 19. I have three clients: converse.js (phone), conversations (tablet) and gajim (desktop).

    If I can help you just tell me.


  • It seems that I only get two messages if the other is online too.

    I will investigate it further or simply reinstall converse and delete the saved data.


  • Hmm, should be fine according to this:

    But it definitely sound like some message carbon related OMEMO issue.

  • I reinstalled converse.js again, deleted cache ... via ut tweak, .... and autologin works now.
    But still I those omemo warnings.
    Do you need a screenshot? If yes: how do I do a screenshot? 😉

    May I can ask one further question? I saw at the screenshots in openstore that it should be possible to send a file or picture. Do I have to activate this feature somehow? Because at the moment I see no paperclip while typing a message.


  • @redi
    To take a screenshot, you have to press vol-up and vol-down simultaneously.
    That's the extend of my knowledge 😉

  • @redi

    I really don't know how to fix the double message issue. I researched it a bit and i seem to be correct that it is message-carbon related and needs a special implementation on the client to discard double messages. But I don't know if this a specific issue with your setup or a general ConverseJS problem. I tried to get an answer in the official ConverseJS MUC, but so far no luck. but if you want you can raise an issue on their github repository with a detailed description of your problem.

    The file or picture sending needs no special configuration but http_upload support server side. As soon as that is supported the paperclip shows up. It is a bit odd that reports this functionality on the compliance page but it doesn't work for you. I run my own ejabberd 20.02 server and there it works fine.

  • @redi is this in a OMEMO encrypted 1:1 chat or a MUC? Seems like there is a specific related issue in OMEMO encrypted MUCs, see here:

  • Strange. It happens in direct chats. And of course trashserver supports http-upload.

    Trashserver itsself works fine. These problems only happen with the converse.js client. With conversations and gajim everything works well.

    May it be a problem caused by the bosh / wss configuration?

    I added both to the server configuration. In that case which connection is used?


  • @redi In that case it should prefer the websocket connection. But to be honest, I am really only testing it with websocket only in my setup.

  • I switched to websockets, but it doesn't solve the problems.

  • pict200405201351.jpg

  • @redi I played around with it a bit and it seems that on 1:1 chats the paperclip sometimes disappears for unclear reasons. closing the 1:1 chat via the top right X and reopening it works on my setup to show the paperclip again.

  • Great. Now upload works now.

    Thank you very much.

  • some further investigations about the double messages:
    (1) If I send multiple messages to one person quit fast after each other, the I get only one omemo warning.
    (2) Although warning and message have the same time, they do not arrive at the same time.
    When I send the message the warning is displayed later although the same time as for the message is shown.

    Could it be that the warning is caused by a read confirmation or something similar ?


  • @redi sorry, but I really can't help you with that. You might want to raise an issue on the upstream conversejs repository:
    Please mention that you are using ConverseJS 6.0.1 with my Ubuntu Touch wrapper.

    It might very well be a known issue given the complexities around OMEMO. I know that just recently a draft for the revision of the official OMEMO standard was submitted that among some other bigger problems tried to solve various multi-client edge cases.

    But to be honest, I would not expect it to be fixed any time soon 😞

Log in to reply