Problem upgrading MX4 from OTA15 to ubport



  • Hi everyone.

    I'm using a brand old MX4 from quite the day it was available, a Utouch version out of box.

    I used to stay on canonical OTA15 since i didn't want to bother myself upgrading (problem with data export that i solved yesterday, lack of recovery wich i talk about later edit : not a problem, recovery is "empty" on that devie, its normal).
    But now i can't even use apps from open store, and lot of mine are deprecated (and i solved data export lol).

    So i jumped the step and tried to update with ubport, but i can't make it, stuck on "cache formatting" and then "lost connection".
    I tried 4 different usb cable, and same result.

    First of all, phone's not auto detected by ubport, but manually it works, the fastboot part's working (some stuf written on screen, no errors EDIT : the fastboot was working because i installed ADB only for fastboot mode at first) and then it goes to recovery mode and that's where it get stucked.

    I tried severall times, severall usb cable like mentioned above.

    Then i tried SPFlash Tool like with a flyme MX4, to reflash my uTouch MX4 with (edit : very old) "stock" canonical img.
    And it worked!

    Then i tried again with ubport to go 16.04 UBP img, and same as earlier, get stuck same point.

    I must say something else : i can't access recovery, and that, before and after using SPFlash tool to flash the phone, when booting with vol up and power, i get a screen with canonical logo and nothing else. edit : normal behavior

    And after trying upgrade with UBport, if i try reboot in recovery the screen is changed, with another logo and a [not]running empty bar under, the same that appear during ubport process.

    Another thing, i broke screen and changed it by an OEM one, the i bought another MX4 to have a genuine one agein (oem lightning quality was poor), don't know if that can brake recovery. (edit : that is not)

    My PC is running W7.

    Help would be wonderfull.

    PS i'm not english so pardon my poor language ๐Ÿ˜…



  • I quite feel lonely here ๐Ÿ˜ข

    Anyway some pictures to show (taken with my flyme MX4 lol).

    Recovery before attempt to update with ubport (and after installing OTA15 very old canonical image with SP Flash Tool) :
    text alternatif

    Recovery after :
    text alternatif

    Ubport get stuck here about 1mn (meanwhile MX4 shows the "recovery after" screen) :
    text alternatif

    And then i get this from UBports intaller :
    text alternatif

    Also as a workaround i tried to flash my flyme MX4 with SP flash tool then with UBport, but nothing happens when trying, SP Flash Tool won't recognize it (i assume it's a non flashable one).

    Now i'm stuck with my MX4 with likely no apps, no store, so impossible to restore data i saved (i used wifitransfert to workaround the "no recovery menu" issue to backup my phone before attempt updating it).

    At least, could someone tell me where i can find a UBPort image i can use with SP Flash Tool as it works very well to flash my UT MX4? I searched here and the internet and only found one topic here ( https://forums.ubports.com/topic/406/mx4-flash ) with a dead link ๐Ÿ˜ญ



  • I can't help you with your problem but are you on Telegram? If so you can join the welcome channel and get good help there, if you don't manage to get help here (not everyone reads the forums regularly).

    ๐Ÿ‘‰๐Ÿป Link for UBports Main Telegram channel



  • @Keneda The images you want are here http://docs.ubports.com/en/latest/userguide/install.html#install-on-legacy-android-devices Also the image with the ubuntu and black oblong bar was what you wanted it can take 15-20 mins from there to install first time.



  • @Loops
    I don't have telegram but maybe i'll check that if i don't succeed here.

    @Lakotaubp
    Thanks but no, this image is Ubuntu from canonical, the very one i flashed with SP flash tool like said above, the one i need is the last ubports one (or at least one that let me OTA update to the last one).

    The image with the ubuntu and black oblong bar is what i want to pass through yes, but ubport software just get stuck at that time like i already said :

    text alternatif



  • @Keneda Right, if you have theCanon Canonical image working correctly all you need is the UBprots Installer. First double check dev mode us on and that adb detects the device correctly. Choose the wipe option when asked and that should be it. One tip when adb detects the device tape everything down. The connection on the usb port on mx4 can be a big problem. You may need to try a few cables. One that works on another device may not on the mx4. Good luck, keep persevering.



  • @Lakotaubp

    Dev mode is on.
    Don't know how to directly check adb works but drivers are installed like asked in UBports software, and the fastboot part of the update is working well in UBports, software correctly exchange data with phone and then go to recovery, and then get stuck, same point, each time.

    I think if USB cable was the problem, it would not work with SP Flash Tool either.

    I really think my problem is recovery not working properly, like i said, when i boot recovery, i don't have any menu, any choice, only thing i have is this, even after fresh canonical image install :

    text alternatif



  • @Keneda Fastboot puts recovery onto the device, then from there it down loads and pushes the file s to the device. If the first bit has worked you should have UBports recovery installed at least. Reboot to fastboot then in a terminal run fastboot devices and see if your device is listed. If it is thats one issue sorted.
    Just noticed your on Windows. Please try 15 sec ADB from XDA developers it works well with windows https://forum.xda-developers.com/showthread.php?t=2588979

    Edit: As I said just because a cable works with one thing don't rule it out. Try another if you can.



  • @Lakotaubp

    Edit: As I said just because a cable works with one thing don't rule it out. Try another if you can.

    I tried all cables i have home, 4 at first like i said in my OP, and later a fifth, i also tried all USB2.0 ports on my PC (as 3.0 may cause problems).
    I'll try adb thing later.



  • So i tried adb and it doesn't work, been trying for almost one day switching drivers, cables and so, and nothing happens when doing the adb devices on console.

    I'm very desapointed as i use this phone since 2015 for daily use and now i can't do nothing with it...

    I'm stuck with a deprecated flyme MX4 or a UT deprecated one, more deprecated than before since i noticed the image given here with spflash tool is a "r26" one and not the last OTA 15 i had before.

    I think my only way out would be a ubport image that i can flash with SP Flash tool as this is the only program that works for me.



  • @Keneda One other thing you can try is a live usb stick with Ubuntu installed on it, and run everything on that.
    Edit: r26 was Canonical the installer should just work with it if we can sort the ADB issue. Trying to remember anything else done to fix this in the past. You could try searching the net again for answer or maybe someone here will have an answer. I will check back tomorrow.



  • You are not alone. I have tried to install Ubports on my Meizu mx4 Ubuntu edition for nearly a year nothing works and I have tried all recommendations I got from telegram nothing worked. I think it must be some problem with the installer because I have tried to install both from Windows and Ubuntu computer and tried many different cables and it seems to be so for many with the Ubuntu edition



  • Ouraaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa!!!!

    I suceeded!

    Now i'll tell what was the problem if that can help anyone ( @Masayoshi maybe i.e) : ADB driver must be installed 3 times for 3 "differents" devices (but same phone).

    In fact, when you connect MX4 (whatever mode) to the PC (windows at least) it detects it as a new device and then installs driver (or not, or you don't let him do and then install it yourself, anyway...).

    As i understood from beginning, we must install the ADB driver when plugging MX4 in fastboot mode (what i've done before doing this topic).

    text alternatif
    But that's not all!

    In normal boot, connected to PC, in dev mod, they are 2 devices for MX4 (not every time...), one must be MTP drived, the other need to be ADB drived.
    Now when you connect it to PC when UBPort software asks it, it auto detects the phone, and you don't even need to reboot in fastboot, software makes it itself!

    text alternatif
    In "Alcatel ABD Device", "Android ADB Interface" was MX4_Ubuntu_Edition before driver install (ADB)
    In "Appareils mobiles", "MX4 Ubuntu Edition" was the same before driver install (MTP)
    To be sure wich one is, enable/disable dev mode in phone, when it's off, only one device is here (MTP one)

    But that's not all... again!

    We must install ADB driver when plugging phone to PC into recovery mode too!
    text alternatif
    In recovery PC sees only "MX4", install ADB driver here.
    If not, after UBPort software auto-detects phone and then reboots it in fastboot, and then in recovery, it looses connection to phone...

    I must say something else, ADB drivers installed for each normal, fastboot and recovery MX4 "device", only normal and recovery mode give me a "ping" in an ADB command shell, but adb's working with UBport software when in fastboot so not a big thing...

    text alternatif

    And now the graal (it has been the longest 4 days for me since a long time... ๐Ÿคช ) :

    text alternatif
    text alternatif
    text alternatif

    Now i'm trying to restore my data, another quest for me lol (contacts done, but MMS and attachment not working).



  • Well done on both install and persistence. I think the adb connection "path" between the installer and device was getting lost at various points during the process. Still your there now. Enjoy.



  • @Lakotaubp said in Problem upgrading MX4 from OTA15 to ubport:

    Well done on both install and persistence. I think the adb connection "path" between the installer and device was getting lost at various points during the process. Still your there now. Enjoy.

    When i only had adb installed for "fastboot device", i lost connection each time exactly the same point.
    Same when i succeeded having MX4 recognized by UBport by installing ADB for "normal" device, was excited as i though i won, and then, exactly same point, just after entering recovery, bam!, lost connection.
    That's what made me think "hey, could there be a "recovery device" too?"...

    PS : i'm not the giving up kind, yes ๐Ÿคจ


Log in to reply