OnePlus One Installation Trouble !!!

  • Hello. Sorry to bother but I could really use some help. I need a smart phone for a job that I'm trying to get as I'm currently unemployed. Originally I bought an Apple iPhone SE the four inch screen is too small and it's Apple (Privacy). But then I decided to buy a OnePlus One phone in mint condition. That came with an older version of CyanogenMod mod version 13.1. I tried all night to install UBports OS version ubports-installer.0.4.17-beta on Windows 7 Pro. And most of the night Windows acted like it could not see the phone. After looking closer at the error which was from the very beginning this device did not install properly on Windows tooltip which included the link "more info" which had the red X saying that the driver did not install. I also used the program "bacon root toolkit" and in using that it took me into the Windows device manager and I saw the yellow Exclamation Point on the A0001 phone device which later became an Android device wasn't working properly. So I went in search of OnePlus One phone drivers and found this file. Which I installed everything looked good it put a green check on the device for the phone in the device manager the properties tab said "this device is working properly" everything looked good. I try again to install with UBports installer but this time it said there is a new version available so I downloaded version ubports-installer.0.4.18-beta and it still seemed to not recognize the device but I chose OnePlus One off the list and Stable and Wipe Data and clicked all the buttons. And for the first time it was talking to the phone I did see "OEM unlock" it said something about firmware. And for the first time the phone screen which had up until that point only said "fastboot loader" in the middle now had the android green and yellow robot in the middle and then changed to a white rectangular text box saying "processing some number of 149". I let that finish it took maybe 10 or 15 minutes. I don't remember if the phone rebooted itself or I used the buttons but I finally saw a new boot screen with the red one with a square plus powered by UBports in the middle and at the bottom sponsored by UBports with the icon and I got really excited. Until that's all I saw. The only other thing I can get the phone to do by pressing the buttons is turn off and on and going to a recovery screen which also now has the Ubuntu orange robot guy. But none of the choices do me any good there's reboot and shut down there is update which then ask do I do it internally and I've got nothing internal on the phone image wise to use and now if I plug it into Windows and this is the biggest problem now it doesn't recognize the phone at all because it doesn't see anything this is a big problem. And yes I tried the wipe partition and factory reset I get nothing. It looks like there is a directory structure of folders like download but they seem to be empty. I did three days of research before I started this and downloaded and installed everything I could find like ADB and Fastboot and the entire Android SDK and
    updated my Java and eventually the OnePlus One Windows drivers. This shouldn't be this difficult. This phone model was said to be the most popular for this OS upgrade and done on Win7 the most popular computer OS right now. So I don't know it looks like the UBports installer obviously did something and got halfway through maybe but where's the rest of the operating system is there a way to get the ABports to work is there a way to get my CyanogenMod back again even the older version reloaded or a new version of Lineage OS. Because right now I have a $100 very pretty shiny doorstop. As you can imagine this makes me unhappy and truly sad especially with everything else that's going on right now. Any advice or help would be greatly appreciated. God bless.

  • @magnolia_dude Ok you have UBports recovery thats half way there. Firstly remove all other versions of adb and fastboot from your pc and install this one it works best with windows. Next we need to check adb can see your OPO. Check the commands for windows when using adb. Open a command prompt and type
    adb devices .... your device should be listed. If not we need to sort that. When connecting keep an eye out for the grant connection permission box if you have not done that already. When you have the adb connection try the installer again with the wipe option checked. Let us know how you get on any issues just return here. Also try a few different usb cables. They can be a big part of the problem.

  • Thank you Lakotaubp so much for your help with my post. I tried LIVE USB Ubuntu and Mint and they both ran out of disk space downloading the softwares so I actually installed Mint on my hardrive. Downloaded and installed Snap and UBports snap file and ADB and Fastboot and typed "adb devices" in terminal to start the daemon and THEN ran UBports installer program and that worked. It immediately recognized phone as Bacon. I went thru the steps and it worked. The fact that these simple steps above are NOT all mentioned in one place on the UBports website or in the video that shows the install is disappointing. I and many others spend hours trying to get this to work when all we needed was the COMPLETE information from the beginning.

  • @magnolia_dudeFirstly glad your all sorted and enjoy Ubuntu Touch. Windows often throws a spanner in the works unfortunately. Things get lost during the process which is why we say to use the 15 sec adb version on windows and to remove other phone drivers. Why it happens I'm not sure, I never had an issue once I had 15 sec adb installed but others have. Some don't even need the 15 sec version. Which is what makes it awkward when adding or not adding info to the install instructions. Still maybe something to keep in mind.
    The snap version of the installer is in my opinion the easiest version to use and you can watch progress in the terminal.