File explorer PC files smb acces



  • Hi!

    How can i access files on my PC (windows 7) with file explorer app using SMB?
    Is it working?

    I activated network share on PC, i use wifi via internet box, and when i select network in UT file browser i see workgroup and if i access it i see my box and PC.

    But if i try access my pc i get the error in UT file browser :
    Handling file error
    path or url may not exist or cannot be read: smb://pc_name

    I know it worked some time ago with old canonical ut and old file browser, then it stopped working because of a crash bug with last canonical ut file browser when trying network access in it.

    But now network in file browser is working again i'd like to use it.

    What am i doing wrong?

    PS : It also worked on androïd with ES File Explorer.



  • @Keneda I have no problem accessing smb shares via wifi on my FP2 (OTA11). What does not work is adding them through clicking on "network" and "workgroup" in the file manager. Try adding the URL manually as item, the share will appear with a symbol for a file not folder. At least worked in my case. You can then add it to "places". Loading large folders is quite slow and can take a while (e.g. large music library).



  • @nogoogle said in File explorer PC files smb acces:

    Try adding the URL manually as item

    How and where? URL is smb:// ?

    EDIT : i tried add smb://pc_name as new file and new folder in file manager, didn't work, same with trying access this in browser.



  • Go to your home directory and open the file manager places configuration file:
    .config/com.ubuntu.filemanager/places.conf
    in a text editor. You will find a line starting with

    userSavedLocations=/otherplace/otherdirectory

    add your URL for the smb-server at the end after a comma. The line should now look something like

    userSavedLocations=/otherplace/otherdirectory, smb://pc_name/smb_target_share

    Save it and restart file manager. "smb_target_share" should now appear under "places" in your file manager. Tap on it and it should connect (at least did it in my case).



  • @nogoogle
    Thanks. Sadly i have exactly same error as with using Network "folder".
    Maybe something on windows side.



  • I tested with flyme 4.2.8.4A MX4 file explorer i have, and it worked.
    It asked me for Nick and Password from my computer account, and then i was able to explore files.

    So it's not windows side problem.



  • Do you can transfer files from phone to your smb share? I get an error message "Could not create the directory: OK". The other direction is working, I can copy files from my smb share to UT/my phone.
    screenshot20200620_165406480.png



  • @herr-b said in File explorer PC files smb acces:

    Can you transfer files from phone to your smb share?

    No i can't anymore between my uTouch phone and my windows 7 PC, that's why i created this topic in the first place.


Log in to reply