no birthdays on contacts?

  • I just started playing around a bit with UT on a Nexus 4.
    Installed the "edge" after trying out the stable and having some issues with Dekko 2 email sync not working as supposed.
    Also I like the layout of the UI that I have now more.

    I'm using German language and have following build: 2020-04-15; 20200414-31749; Ubuntu 16.04LTS - armhf (20200414); 20181229-15118; aosp_mako-userdebug 4.42 KOT49H 20160330-0939-0ubuntu1~overlay1 test-keys

    But now to the thing I'm missing.
    I have imported a .vcf file with all my contacts. These include birthdays for some persons.
    On the UT contacts app I can't see any birthday nor is there an option to add one.
    Is that supposed to be like that?

  • Hi @Mystic-X and welcome here.
    Yes that is expected.

    The contact app manages only few fields from the VCF.
    I think there is already an issue on gitlab about this.

    My workaround is to use a Nextcloud instance. Mine is on a personal server but you can use a service offered by some third party.
    There I imported my VCF. Then I made the birthday available as a calendar.

    My calendar is synced with my phone.
    I never tried to sync my contacts as it is easy to export when I change phone.

  • @Mystic-X hello, i'm working on it, will land hopefully soon, at least for having a birthday field on the contact app

    follow-up here:

  • @lduboeuf
    OK, tried it out.
    birthday is now displayed on the contacts app.
    maybe you change date displayed a way it shows the year full.
    I see now: 11.02.87 for Febuary 11th of 1987. Would be nice if it would show: 11.02.1987 or is that a thing that I can set globally?

    Adding a birthday to a contact that had none works.
    editing a brithday works.
    deleting works too.
    If I just deleted the birthday field using the little X icon I'm not able to directly add a birhtday field afterwards.
    Day displayed seems to be correct.
    a tap on the little calendar icon behind the birthday opens the calendar app but jumps to todays date.
    no birthdays loaded as events in the calendar so far.

    Does look promising so far! Thanks!

  • @Mystic-X
    thank you
    for date format, it is default locale format applied, mine is e.g 18/07/1980
    yes known bug for calendar not pointing to the right date
    And the cannot re-add a birthday it is a general issue not specific to birthday
    For birthday synchronization with calendar issue, have you enbaled it in calendar settings ?

  • @lduboeuf
    OK I had to disable the birthday calendar once and enable it again and now it shows the birthdays in the calendar app. fine.

Log in to reply