Still a Dekko2 question...



  • Hello,
    some days ago I got a Nexus5 and tried some things out. So far so good. Got many things working and some other not.
    But I can't solve the sending mail problem in dekko 2. I configured my mail account, it's my own mail server, and I could read all my messages.
    But after searching the forum and read many posts I'm a little bit confused.
    I tried out to reinstall, to delete cache files, delete everything and reinstall but it won't send out a mail.

    But I am somewhat irritated by the fact that there are teweets and likes telling there are no worries. If there are no worries with dekko2 and the community like this tweets why nobody can give a hint how to solve it?

    Maybe there is someone who have a second to give me a hint where to search for a solution

    Regards

    03.png



  • Hi. I understand your frustration.
    Invariably when Dekko does not send mail but everything else works, it has to do with the configured settings. Please double check the server, port number, credentials and log in protocol for the outgoing server.



  • Dekko has some uncommon options, like under authentication type and force ssl/tls - you should probably try changing those around a little.

    I noticed, for example, that GMAIL defaults to "plain" authentication but requires "login" ...

    If that doesn't work, please join us at the dekko user group on telegram and we'll try to help!



  • as first, thx for your answers.

    I've reinstalled dekko checked the log file. It looks like a SSL Error.
    Now I'll search again for the solution

    If someone interessted in the error log:

    [3642] Apr. 16 11:09:25 [Debug] SMTP :  newConnection
    [3642] Apr. 16 11:09:25 [Debug] SMTP :  Open SMTP connection
    [3642] Apr. 16 11:09:25 [Debug] Messaging :  QMailTransport::Socket::Socket SET PROXY host= "" port= 0
    [3642] Apr. 16 11:09:25 [Debug] Messaging :  Opening connection -  "searx.li" : 587  SSL
    [3642] Apr. 16 11:09:25 [Debug] Messaging :  SMTP : connection established
    [3642] Apr. 16 11:09:25 [Warning] socketError: 13 : "Error during SSL handshake: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol"
    [3642] Apr. 16 11:09:25 [Debug] SMTP :  Closed connection: "Socket error"
    


  • Have you tried to choose STARTTLS instead of SSL in the smtp settings?



  • Ok, solved. Thx to the guy on Twitter. His tip was to create a Identify in Settings. After create one and switched back to STARTTLS it works.

    Thx guys !



  • @hummlbach

    Yes I have, tried both. But it worked only with a Identity in Settings

    THX


Log in to reply