Sony Xperia X Performance (dora/F8131 & F8132)

  • @Andreas-Pokorny Ahoi Andreas! Im Not asking for ETA, only if you intend to "finish" this port? If so, would it be of help if i provide feedback? Im a plain user and dont know s**t about code. But my fp2 died and I need a different UT device and dora is great and right now the only one thats waterproof.
    Anyway, thanks for your effort and your contribution that youve already done.

  • @zapfel said in Sony Xperia X Performance (dora/F8131 & F8132):

    But my fp2 died

    Can't you repair it? It's an easily repairable decive normaly.

  • When i was at the beach i dropped it in the atlantic ocean. It took me a couple of minutes to find it again. I exchanged parts with my wifes fp2 but no sign of life from any of the parts. Youll get a used dora for 100€ and its waterproof 😉

  • Most of the things work great! I also managed to install anbox. That went well for the biggest part, however there is no network or wifi available within anbox. How can I make that work? Perhaps some kernel modules are missing?

  • @Andreas-Pokorny Hi Andreas, I just tried to install Ubuntu touch as you described. It worked fine until I started with the Installer. Somehow my phone goes into a loop of booting as soon as the Installer is downloading the OS and preparing the image. It then asks me to reconnect my phone and try again. Any help is appreciated 🙂

  • @CB1929 I remember having the same issue and I think I solved it by first putting the phone in fastboot mode, connect phone to computer, start the Ubports installer and then select by hand in the Ubports installer the Xperia X Performance phone.
    I also needed to do this: Flash the OEM binaries from: using fastboot flash oem SW_binaries_for_Xperia_AOSP_N_MR1_5.7_r1_v08_tone.img , because even with the updated Android 8 it did not boot.

    Hope this helps.

  • @herkovb I tried that too, did not work though. I managed to do it by now, it worked just fine after installing TWRP and erasing the above mentioned data 🙂

  • Hello,
    Any updates regarding this port? Andreas is the only one maintaining it?

  • @CB1929 Does installing TWRP delete the OEM binaries or is that another step. I'm having the exact same issue that your were having. I completed the step above to install the binaries, and then saw your comment about TWRP. Thanks!

  • So does it mean I can install ubuntu touch in Sony Xpedia xz1 thought installer without changing any config or any special steps?

  • @kophamerla I think it is just another step, at least I did not have to reinstall the binaries afterwards and it works just fine now. Good luck!

  • For those having an issue with the never ending reboot of their Sony Xperia X Performance when trying to install, and having issues gaining access to TWRP. Please follow these instructions, it will fix all issues.

    1. Start your phone in fastboot

    2. In terminal make sure your device is showing up. Type "fastboot devices" and your phone should appear in the list.

    3. Make sure you know the path to your TWRP recovery IMG file (twrp-3.4.0-0-dora.img). I just open terminal in the folder where the TWRP IMG resides, and then enter the following command,

    "fastboot flash boot twrp-3.4.0-0-dora.img"

    Remove the usb when complete and reboot the phone, it should startup to TWRP.

    1. In TWRP select, "wipe", "format data"

    2. Don't wipe everything, just wipe "data", "system", "dalvik", and "cache."

    3. Reboot to bootloader and use UBports-installer to flash again. The installer first flashes UBports recovery, then the phone reboots and automatically goes into UBports recovery, then the system is flashed.

    Let the installer and phone do their thing, it should work.

  • Andreas: In the status/working area of your first post, USB/ADB is working. Does this work similar to the Nexus 5 and allow tethering?

  • Hello everyone.

    Hope you are all safe.

    I installed the Ubuntu Touch on my Sony Xperia X Performance. After that, I received almost daily updates. However from beginning of June, I have not received any update. I'm on the Development Channel. The last update I have is:

    • OS build number: 2020-06-07
    • NOF27B 53 test-keys

    I also tried to reinstall the OS by using the UBProts installer, but it stays on through same build number as shown above.

    Are other here also on the same build number and not receiving any updates?

    Cheers and thanks in advance for the help and/or responses.


  • Will this work on SOV33? That's the one I found locally so far.

Log in to reply