Sony xperia x kein G2,3,4 und keine Kamera (Sony xperia x no G2,3,4 and no camera)



  • Hallo,
    ich versuche es mal auf Deutsch.
    Erst mal möchte ich sagen, daß ich von dem UB-Ports-Projekt total begeistert bin. Ich nutze seit 3 Jahren erfolgreich ein BQ Aquaris E5.
    Nun habe mein neues Sony Xperia x F5121 auf mehrere Art und Weise versucht zu flashen. Aktuell ist nach der Installation mit dem UB-Ports Installer 0.4.18 beta folgender Stand:

    • die Kamera-App startet nicht (hängt beim Startbild)
    • habe keine mobile Daten egal ob 2G, 3G, 4G.
      Ich bin inzwischen ratlos.
      Wer von euch wäre bereit mir das Handy so zu bespielen, daß es funktioniert? Bitte um Antwort..

    Vielen Dank
    Reinhard



  • Hi!

    Please, try to write in English... I'll try to translate...

    Hello!
    I try in German.
    First of all I'd like to say I am flabbergasted by the UBports project. For 3 years now I use a BQ Aquaris E5 successfully.
    Now I've tried to flash my new Sony Xperia X f5121 in different ways. Right now after installation with the ubports installer 0.4.18 beta I have the following result:

    • camera is not starting (hangs with the starting icon)
    • no mobile data possible, neither 2G, 3G nor 4G
      I don't know what do to.

    Would someone be willing to flash the device for me, so it is working? Be so kind as to answer!
    Many thanks.
    Reinhard



  • @Ubuntu-Schommel First of all as pointed out please use English on the forum or at least supply a translation. These are the two forum threads for Xperia X https://forums.ubports.com/topic/4147/sony-xperia-x-performance-dora-f8131-f8132 and https://forums.ubports.com/topic/3229/sony-xperia-x-suzu-f5121-f5122/163 please check there.



  • Hello,
    I tried the Installation more times. Now I have had luck. The Phone works.
    This ist what I have done (Sorry for the bad English):

    Flash Sony Xperia F5121
    1.1) Unlock access to the cell phone

    • Activate "USB debugging" and "bootloader access" on the mobile phone in Android (see Android on the Internet)
    • Have the "Unlock code" displayed on the Sony side, stating the cell phone's IMAI (and write it down)
      1.2) Install Android 8
    • Install the "Fastboot" program on the PC sudo apt install fastboot
    • put the mobile phone in bootloader mode (switch off the mobile phone; wait 15 seconds; hold the volume up key down; plug in the USB cable; if the LED lights up blue the connection is established)
    • Check in the terminal whether the cell phone can be reached with "fastboot devices" (the device should be displayed)
    • unlock the bootloader with fastboot oem unlock 0x[unlock code from Sony]
    • remove the SD card first !! (if available)
    • Install the flash tool from Sony under Windows 10 (the software is called "EMMA")
    • Connect the mobile phone to the USB while pressing the volume down button (below) (the green LED lights up)
    • EMMA now finds the cell phone
    • select the current firmware and also the software (34.4.A.2.107.FR .....) and flash (I took version 107 ..., 118 probably works too)
      1.3) Replace the firmware
    • Install TWRP on the mobile phone with "fastboot flash recovery /home/reinhard/Downloads/twrp-3.3.1-0-suzu.img" (download the file from the Internet)
    • Start TWRP with (USB connector pulled + vol-down + power) and then in TWRP "Wipe" data + system + cache + dalvik cache
    • then flash the following file with fastboot "fastboot flash oem /home/reinhard/Downloads/SW_binaries_for_Xperia_AOSP_N_MR1_5.7_r1_v08_loire.img" (Attention, unzip the zip file beforehand !!)
      1.4) Install Ubuntu Touch
    • then bring cell phone in Fastboot mode = blue LED
    • connect to the UBPort installer (manually) and have it installed (version ... devel; wipe data; ...)
    • done (and me too)

    What's not possible (as of May 16, 2018)
    Everything works great (high praise to the "porter"), except for:

    • camera: no flash; no zoom; no video
    • LTE is not displayed, but still seems to work
    • the battery lasts approx. 1 day (seems to be too small for the cell phone anyway)
    • Bluetooth headset is not working

    Alternatives
    I had tested Sailfish-OS in advance, but I am disappointed:

    • I find the operation and the look horrible
    • the app store has practically nothing useful to offer (the open store from Ubuntu-Touch is much better)
    • I also bought the Android extension for € 49, but it is only Android 4.4 - so it is no longer really usable


  • @Ubuntu-Schommel Thanks for using English. Still think it's better if your looking for answers to post in the main device thread https://forums.ubports.com/topic/3229/sony-xperia-x-suzu-f5121-f5122/163 Bluetooth is very buggy though you may want to have a look here https://forums.ubports.com/topic/4300/call-for-testing-updated-pulseaudio-better-bluetooth-headset-support



  • @Ubuntu-Schommel
    Ich habe eine Frage: hast Du noch der bq E5? Ich habe eine Problem mit alle eingehenden Anrufen > Kein “Telefon“ app (Fenster).
    I've a question: Do you still have the bq E5? I have a problem on all incoming calls > no “phone“ app/windows.

    Sorry for broken english and/und tut mir Leid fur die deutschen Fehler !


Log in to reply