Oneplus One install failed: cannot flash Ubports recovery

  • Hi All, it seems there have been a few people having trouble installing on the Oneplus One recently.

    Could someone point me towards the manual installation instructions? They don't seem to be on the site.

    adb/fastboot is working ok, I have tried many installer versions but cannot get the ubuntu recovery to install.

  • @yeke_yoke Just to check all the obvious done, dev mode on, bootloader unlocked(oem unlock) MTP/file transfer mode on, usb debugging and permission for the adb connect granted.

  • @Lakotaubp Appreciate the help.

    Yes, all of the obvious done. Each one of those points completed.

  • @yeke_yoke Phone in normal mode does

    adb devices
    in a terminal show your device? If yes try

    adb reboot bootloader
    fastboot devices

    If that shows your device you should be ok. Any errors need to be sorted

  • @Lakotaubp Yes, adb and fastboot both show the device. The install still fails. What's the next troubleshooting step?

  • @yeke_yoke What OS are you using and what happens, have you tried different usb cables and or ports?

  • @Lakotaubp Using Mint 18.3 and have tried several different cables.

    When I run the installer (I have tried some older versions of the installer as recommended in other posts on oneplus one install problems) it reboots to bootloader and hangs when trying to flash the firmware.

  • @yeke_yoke I had no issues with mint ( not that that helps)are you trying the .deb or snap installer. Try rebooting phone to recovery and clearing cache and all you can then choose the wipe option on the installer

    Edit: There are a few reports of success with the Appimage installer like this one Might be worth a try.

  • @Lakotaubp I tried a fresh install of latest mint 19.3, trying the deb and appimage installers. It didn't work.

    Then I removed the deb installer and installed the snap installer and tried that with the usb cable of a friend that had just arrived. Something different happened - the Ubports recovery was now installed but the next step of downloading UBports to the phone was not happening.

    After retrying the installation several times it started to push Ubports to the phone but was losing the usb connection and halting with the error message every 30 seconds, so I just clicked "try again" each time and the process completed. Success, finally.

    I suppose the issue from the start may have been usb cable, but I honestly tried 4 or 5 different cables and even my friends brand new one was losing connection.

    Unusually, Ubports is now showing the phone as having 16GB total storage when it is the Oneplus One 64GB model.

    Thanks for your input @Lakotaubp, I'll mark this as solved.

    edit: How do I mark the post as solved? I think I read in another thread that new users cannot do that.

  • @yeke_yoke Well done on sticking with it. Cables can be a nightmare at times. Something must have been interrupting the connection but it's sorted now. The solved bit is in Topic Tools. mark your first post as Ask as question, then go back and change the unsolved to solved in Topic Tools again. As for the storage try restarting the device if that doesn't fix it reboot to Recovery and clear the cache, all those interruptions may have left stuff lying around. Anything else you know where we are.

  • @Lakotaubp well done to you for the work you put in on the forum - I've read a lot of installation problem posts over the past few days where you are helping out.

    I've installed Ubports on a family member's phone and they have been using it successfully as a daily driver for the last couple of years, and have contributed to the foundation, so it's great to see the project go from strength to strength with the pinephone and everything else.

Log in to reply