Can't make or receive phonecalls pinephone



  • Hm. Calls work with me. Also Germany but carrier is Telefonica.
    But the phone disconnects from mobile connections while morph browser is running. And the Wlan disconnets after I click on a link on any website and only loads after reconnecting... 😉
    ...but compared to 2015 everything is still amazing.



  • i have the CE phone on AT&T in usa.
    I left the choice for 2g or 2g3g or 2/3/4g Blank , did not select anything
    made a new APN for LTE ( it may not really be LTE ,works for me)
    rebooted and wallah !!!
    most times it only wants the name of your provider ,for me
    NAME Consumer Cellular
    APN ccdata

    do not try to put passwords in skip that



  • I somehow just managed to make a call after I set it to 2G/3G/4G and APN Name Vodafone, restarted the phone and then just clicking on Carrier.

    I'm happy now 😁



  • Did you make a system update first? The factory image of the Pinephone is old. We did not manage to get all features in, so the first thing you want to do is to head to system settings and do an update there.



  • @Flohack yes my system is fully up to date, tried many different settings and nothing works 😞



  • @Flohack Now suddenly calls started to work for me. I have no idea why? because I did not change anything, it works now although I hear the other person very bad.



  • Hi,
    My carrier in Poland is Orange. What i noticed so far is when i change Cellular settings to 2g/3g/4g i cannot make any calls and if i try to call from another phone to my Pinphone i get message that this number is not available at the moment.
    I can make calls with 2g and 2g/3g
    The funny thing is that when i'm switched to 2g only i get the best mobile reception quality - reception triangle(not sure if that's correct name) is completely white.
    With 2g/3g enabled i get only 50% white and 0% with 2g/3g/4g

    Besides that I'm randomly completely out of range on my PinePhone while my OPO is running with LTE



  • My Calls stopped working again after a restart, did not change any settings.



  • @TheTrell let's hope it starts working again. Mine still works (knock on wood).



  • @TheTrell check your setting after the reboot things change, try ,not selecting 2/3/4g leave that section blank, but double check your data is still turned on, and look at your apn and make sure you have the little box ticked/checkmarked (turns it green).
    good luck



  • Not to disrupt the conversation to much, because it is important regardless.

    From what I understand, when you've found out what this problem is, the pinephone still wont be a usable phone device, because acording to the gitlab resource, the microphone doesn't work, and I dont think that you can use a bluetooth microphone to fix this, because I tried a bluetooth microphone with a recording app, and it just said that it didn't have permissions.

    I think that if you want to do calls you have to wait until apparmor is properly implemented in the OS, however, I would love to be proven wrong because I wanna call on my pinephone!



  • @PhoenixLandPirat For me microphone works fine and i can make calls. On Gitlab indeed microphone is marked as not working but maybe that's different use case (for example video conferencing apps )



  • My calls still works but when I'm in a conversation I can barely hear the other person even though I have the volume on the highest. Other people can hear me excellently though 🙂



  • @KarolinaK I am having the exact same issue. Call volume and the overall volume of the phone is not loud. I can't hear it ring when it's in my pocket when I'm out in public. I can hear other people in a call, but just barely. My volume is turned all the way up.



  • Allright got it working again.

    Connection type:
    2G/3G/4G

    APN is set to:

    Name: Vodafone
    APN: web.vodafone.de

    turns out every time I do a restart calls completely stop working, but I've found a method that seems to be working reliably:

    When restarting always Power off instead of using the restart option.
    Once everything is back on go to the Carrier & APN settings tick the little box next to your APN again
    then manually select the carrier again.



  • @tricky 4G is only for internet, it doesn't support calls. When calling, the phone (regardless of OS, type or carrier) will change automaticly to 3G and after the call ends, it will turn back to 4G.



  • @C0n57an71n
    4G Work for calls if carrier and phone support VoLTE, voice over LTE.

    https://en.wikipedia.org/wiki/Voice_over_LTE



  • On the OP3 and other devices, you can select 2g/3G/4G and its fine, but on the pinephone it can have difficulties if you don't manually select 2G/3G.

    I don't think people care to much about not being able to use 4G when they're in a phone call, but just that they cant get phone calls if 4G is selected as an option.



  • I'm on T-Mobile in the US with my Pinephone UBPorts Community Edition phone. I installed all updates from System Settings. But outgoing calls fail. Incoming calls seem to work.



  • @rvndpr
    I was using att (USA),and found if,l left the 2/3/4g settings blank,made no entry, it would work and accept the other APN settings ,and let me check mark the little box


Log in to reply