bq m10 HD touch screen goes nuts

  • Since this morning my bq m10 HD is unusable - whenever I start it, it seems to lead a life on its own. The screen is hardly responding to touches anymore, but works on a "ghost-entries", changing programs on its own, writing weird text in the appearing pass word phrase window etc.

    I had it running on dev channel, and thought this weird behavior was caused by the latest version, 528, which I wasn't able to start at all (no way to enter my pin code, because the field was filled mysteriously with signs on its own) so I switched to rc. I was able to open the screen, but didn't get much further; same behavior as before

    So I switched to stable; at least I was able to open programs, but the indicator panel still keeps opening up, switching between different entries on its own; and as I write this post other programs start to open up to....

    Any ideas what is wrong here?

    The tablet is new, I bought it in March of this year. I had this happening once before, but was able to fix it by reinstalling/changing the Channel.

    EDIT: Looks like a hardware problem - when I run tests in the factory mode the touch screen test shows weird pattern... Could the glass protection I put on the screen cause this behavior? It used to work with it, though. Right now the air humidity is rather high, could that be the reason?...

  • @hankschwie
    Humidity might be the cause, but erratic behavior are frequently due to a loose cable.
    Probably the one from the screen to the motherboard.
    When I had the M10 I never tried to open it, but if you feel adventurous you may open it and check the connectors.

    As it is new I advice to use the warranty.

  • @AppLee

    Thanks for your suggestions! I hope, I don't need to open it...

    After another channel switch, using edge this time, the tablet works again. I thought edge and dev were merged?... Anyway, now I'm back to dev, it works for the time being, and I hope it stays that way.

  • Does anyone know where I can find the m10 ubuntu edition? Im in the US...

    I'm assuming it runs well on that phone because it's native....

  • Nowhere, it is not sold as Ubuntu edition any more; you'd need to get an android device and install UT. (but your post is OT, isn't it?...)

  • @AppLee
    The error returned, so I opened up the device and tried to refasten the cable connecting the touch screen (not that I was able to determine if it was loose at all, though) - hope it helps, right now it seems to be OK again. If not I guess I have to send it back for repairs.

Log in to reply