create boot.img only

  • hello i have been working on porting over to the aristo 2 for a couple weeks now and just found the forum.

    the problem with my device is that no one has completed making a rom for it. the roms available do not boot. so i have been trying to port on my own and not having much luck.

    i have created a repo on github and i have eveey thing i need but i keep getting errors for 9 too many files open and no product spec.

    i really just want to make a boot img at this point. Is there a guide on that some where

  • Do you know what the definition of insanity is? I have read the docs over and over. Not trying to be rude but there is alot about building a device that is missing and i have scrounged around for quite some time.

    But today i made some progress i got the build system to start making a bootimage. But it craps out at after building and installing the kernel modules.

    you can take a look at my source at under android lge cv1.

    the errors im getting are previous definitions in the static and shared libraries which i guess causes a clang++ linker error number 1. ive been pulling my hair out now for 48 hours and i cannot find a solution.

    i can recreate the errors by setting up any device and trying to build

  • @Duhjoker, Have you tried contacting the halium developer community on IRC, Matrix or Telegram as mentioned in the Get Help section of the First Steps Halium page? The people who can help you are more active there than on this forum.

  • yes i have tried. i was very rudely spoken to on telegram and ignored completely every where else. any way im here for some help.....

    im not gonna lie i have been trying to do this for a year and have found my self cut short by either technology or knowledge. Trying to find the right machine with ram and hdd was a problem due to limited funding but i have to tell you when i compiled my first kernel a few months ago and relearned my c++ coding skills it was exciting. so even now today being able to get past the obvious build errors and see make build my kernel with in halium soi9urce i gotpretty happy.

    but after downloading source for my own device and two others jusr to watch them all have pretty much the same errors sucked. i really hope you can help.

    i think part of my problem is due to my device having to be 32bit a 64 wont boot no matter what. so ive tuned the build down to the same.i have removed any dependency that adds 64bit as well. besides i cant flash a 64bit image on a 32bit twrp and my porting it over has failed as well.

    first upon using make or mka its starts saying build/core/ is overriding my target then going to multiple definitions of popcount_tab in for shared and static libraries and ending with a CLANG++ error code 1

  • @Duhjoker, I am sorry you had such an experience on Telegram. I am not in the Halium group myself, but I had the impression they were a helpful lot.
    I have zero experience porting, so I am afraid I cannot help you myself but let me see if I can get someones attention who might...

  • when you setup your environment, are you using the steps in the halium docs? Did you check to make sure you have all the sources for your device? I imagine that you are missing some sources or have a incomplete repo or perhaps missing something with the dev machine

  • actually i pulled every thing from the phone. what did not i did by hand. But i made the list myself. like i said i spent a lot of time preparing for this.

    besides i downloaded two other builds of the /halium/devices/manifests lists and they are giving me the same problem.

  • @Duhjoker what device?

  • @tigerpro said in create boot.img only:

    @Duhjoker what device?

    LG Aristo 2

  • @arubislander where are you pulling the source repos from?

  • @tigerpro This is there source stuff if that helps. I have no idea on any of this (unless 32bit thing being slowly dropped might be part of it, just a thought).

  • a quick look at the dependencies file shows that qcom_common (iirc this is part of halium repos) and external_bson are needed, are you getting these with your repo sync? 32/64-bit at this stage is irrelevant, both are supported, and a 64-bit build can run 32-bit rootfs

Log in to reply