Nmap on Ubuntu Touch

  • Hi everyone!
    I'm trying to install nmap – the desktop app – on my Nexus 7, but i've got some problems.
    The first time I used Libertine, but the download (after 4 days!) is still running. So i tried on terminal, but when i've typed:

    Libertine-container-manager remove-package -p nmap

    it gives me the error:

    package “nmap” in not installed

    so I decided to install it via terminal, but when i've typed

    Libertine-container-manager install-package -p nmap

    it gives me the error:

    package “nmap” is already installed

    LOL 🙂

    What can I do?


  • Why do you want to install nmap via libertine? There is an app provided through openstore. Have you tried that one already?

    edit: Sorry, I've just seen that this app is avaiable for 15.04 only

  • @Palomar Libertine is still not reliable and there are problems with it, as far as I've read. I think you might wanna stay away from it if you don't really need it, but if you want to play with it, it's your choice.
    @kristatos I don't know what do you mean with 15.04

  • @C0n57an71n
    15.04 is relative to ubuntu revision.
    OTA12 is ubuntu 16.04 based.
    Current ubuntu desktop is 20.04.

  • @Keneda Aaahhh.. Gotchyaa... Thanks!

  • @Palomar try deleting the container.
    Set 'lock when idle' to never in the battery settings. Then recreate the container, either in terminal or in the settings. After that install nmap. It should work.

    Also see here for more tips.

  • thanks to all!
    I deleted/recreated the container, after setted "lock when idle" to never. But when I re-try to install nmap, it gives me this error:

    ERROR: ld.so: object ‘libfakeroot-sysv.so’ from LD_PRELOAD can not be preloaded (cannot open shared object file): ignored.
    /usr/sbin/chroot: cannot change root directory to ‘/home/phablet/.cache/libertine-container/xenial/rootfs’: no such file or directory

    I simply wrote this:

    $ libertine-container-manager install-package -i xenial -p nmap

  • Short of telling you to try creating the container again I am afraid I am running out of ideas, as I have never faced that specific issue myself. I also have not been able to find any information on the error message that would make much sense in this specific situation.

  • I think that the problem regards Libertine: i've just tried to install, in the same way, Firefox but... also the error is the same! 😞

  • Must be the combination of Libertine on the Nexus 7 then maybe...

Log in to reply