Libertine Questions

  • After playing with anbox a while I've come to the conclusion that it currently doesn't fit my needs. I'm really excited about it's potential but it just seems too experimental right now. So I'm moved on to exploring libertine.

    I think Morph is fulfills it's stated goals well, but I would still like to find a better option. I tried installing firefox under libertine and it works fairly well, but obviously it's a desktop application and doesn't excel on the phone. I ran across the PaleMoon browser (, it looks like it might work well, and I would like to try it. To install it there is a PPA provided and there is an option under libertine to add a PPA, but 1) that's a lot of typing on the phone, and 2) I'm not sure what to put in the key section.

    So my questions are:

    • What do you put in the key section for the libertine PPA section? I'm assuming the contents of Release.key on the PPA?
    • It seems sudo isn't even installed in the container, so what's up with that? Can you not even do anything in the container that requires root access?
    • If I launch a bash shell in the container can I use standard apt commands?
    • Can I just edit files under /etc/apt in the container?

    Thanks in advance!

  • OK, so I'm making progress. Apparently putting the contents of Release.key is not the right thing, but I did notice that in the shell container the GUI just appears to be updating the files in /etc/apt so I was able to use CLI commands to install the repository key and update apt. However, even though "apt search palemoon" in the container returns results now, it is not an option when searching for packages using the UT GUI. When I try to install by package name it appears to install but really doesn't. So I guess I'm stuck until more knowledgeable folks can tell me what I'm doing wrong.

  • @nontrivial said in Libertine Questions:

    It seems sudo isn't even installed in the container, so what's up with that? Can you not even do anything in the container that requires root access?

    Libertine is an unprivileged container. DO NOT install sudo as it will break some things if you do. To get a root shell if you need one, you can use libertine-container-manager exec bash instead. You can edit apt sources and such this way.

    For what it's worth PaleMoon browser is just a modified fork of a very old Firefox, so it probably really won't work as well as Firefox does, and it certainly isn't optimized for touch based systems like your phone.

  • @dobey Acutally, I suspect I will like it better on UT than Firefox. The main reason is compared to regular Firefox it is a lot faster. The UI is old and clunky, but in this case that is a good thing. For example, the scroll bars and other UI elements are big and chunky by today's standards, but on a small screen I think they will be much easier to actually use. Also, since I assume it reports itself as Firefox, I've visited a few sites on my desktop and it lays out the pages better than Morph. Also I have a site that I really want desktop notifications to work, they work on my desktop, and I hope they work on UT. If they do it will save me a lot of work getting around that. There are a few other reasons too, but the last big one is even though the selection isn't the best, it does have some add-ons/extensions.

    So yeah, I still want to give it a shot, so if anybody could tell me what I'm doing wrong setting up the PPA it would be greatly appreciated. Or I guess I could try installing the deb with dpkg? I would really like to get the PPA working though, just on general principals and because if I end up using it palemoon is updated frequently.

    If it's any help, most packages are listed as name/xenial for apt search but palemoon is listed as palemoon/unknown. Also other packages show up under apt-cache search but palemoon does not. I don't know if any of that is important tracking down the issue.

  • I'm poking around the PPA and I'm seeing references to i386 and amd64, but not arm. So maybe I'm doing it right, but there simply aren't any packages compiled for my architecture?

  • Yeah, digging a little deeper they only have arm packages available for ubuntu 20.04. So I'll ask them if packages are available for older versions of ubuntu, but at this point it looks like I've hit a dead end.

  • Where is the actual PPA? I only saw a link to OBS.

  • Libertine Tweak Tool makes desktop apps more workable on small screens

  • You have to dig a bit but the link is:

    So just to recap, running desktop apps with libertine is not optimal but I would really like an alternative to Morph when it does not meet my needs. I have several issues with Firefox running under libertine, and one of them is where any GUI elements to the right of the address field is in a bermuda triangle alternate reality and you can't interact with them. In other words, you can't click on anything to the right of the address field, even using a keyboard and mouse. That includes bookmarks, hamburger menu, and any add-on indicators you might install. All that to say I fought through getting two more desktop browsers (midori and epiphany-browser) working under libertine and ALL THREE browsers suffer from the same issue. So I don't know what's going on but it's annoying as heck. And yes, the Libertine Tweak took is pretty much required when using libertine on UT.

    And for anybody reading this that migh want to try midori or epiphany browsers out, they install fine but to get them to run you have to execute the following in a container shell one time:

    ln -s /usr/lib/arm-linux-gnueabihf/mesa-egl/ /usr/lib
    ln -s /usr/lib/arm-linux-gnueabihf/mesa-egl/ /usr/lib

  • OK, so not a PPA actually, just a repo on OBS.

    So what exactly are you having trouble with there? You just need to do it inside a shell started with libertine-container-manager exec bash and remove the usage of sudo from the commands.

    But I presume it will then give you an error about there being no Packages or such for the architecture, when you do the apt update.

Log in to reply