Toggle keyboard autocorrect



  • Hi!

    I'm having a minor but frustrating problem with the keyboard. Autocorrect seems to be enabled or disabled at seemingly random times: For example, it is disabled while writing this post (text fields in morph browser), but in many apps it is enabled while entering information like passwords or user names. It seems to always be enabled in Libertine.

    In consequence, I lack the functionality when I want it, and I need to disable it in order to use some apps at all.

    Is it possible to quickly toggle autocorrect on and off from the keyboard somehow, so that I can use if whenever I want to and not when the system decides I should? If not, consider this a feature request. 🙂

    Sorry if this has been asked before, I couldn't find anything searching. I'm on the developer channel on a Nexus 6p.



  • Sadly what you described are mostly bugs which should ideally be fixed instead of adding a new setting to "hide" those bugs. Auto-correct is currently not working in the browser/webapps. I'm not sure about libertine as I don't use it but I'm guessing it's also because libertine apps can't interact with the keyboard to disable or enable auto-correct. Native apps has a way to control auto-correct per field and I think at least that part still works properly.

    Anyway, what you want I think is a bit simple to add in the language dialog (press and hold language icon) but it's a matter if it's worth it for someone to put effort implementing it 🙂



  • Makes sense, thank you. I think it would make sense as an option in the language dialog, but it might come across as a bit too hacky - especially as people might want to keep their alternative layouts. Might make more sense to just wait for the underlying problems to be worked out.

    Guess I'll just leave it disabled for now. 🙂