SMS reception through Anbox

  • Hello,

    I own a FP2 (channel : RC), and my problem is the following : yesterday the government of my area decided that electronical tracing will be mandatory for places like restaurants, museums and such because of the Coronavirus from tomorrow on. And it's unlikely that I can avoid it because of some birthdays that will take place in the coming weeks in restaurants. The only app available for this is SocialPass, which is only available for iOS and Android. The tiny good part of it is that you can directly download the APK file : they have put it for phones which don't have the Play Store.

    Anyway, so I installed Anbox on my FP2, installed the app, and it says that you have to register yourself with your phone number. You then normally receive an SMS with the registration code, and then you're done. But I didn't receive anything.

    I can install Fairphone Open (the Google-free Android version from Fairphone), and get rid of the problem (if it works), obviously. I can also install FP Open, install the app, register myself, then install UT + Anbox + the app and have a workaround. But I wonder if it may be a permission problem before I take one of those steps. Did any of you face this kind of problem ? If yes, did it work ? And what did you do ?

    Thank you very much ! I hope I am clear enough. If not, please tell me !

  • You should have recieved the sms. I doubt the Anbox app can directly recieve an sms but you should get a code that you can input no?

  • @Luna
    Strange issue. If the request is sent using the app you should in fact receive a SMS in return.

    As an alternative, does your government provides a solution for people without a smartphone ?
    For people using a regular dumbphone or without cell phone ?
    I found it strange that a law is able to force people into buying either android or apple.

  • @AppLee @Giiba Thanks for your answers ! I doubt too that the Anbox app can receive the SMS, but as it is an SMS, I should have received it with the UT message app, Anbox or not.

    @AppLee sadly I don't think so. It's because 'analogical' tracing (that is, people are meant to write down their personal infos on a piece of paper) failed : the majority of people wrote down false informations to avoid being sent in Coventry, as it seems. Therefore the government puts its hopes in electronical tracing, because it is less possible to cheat with it. But they don't provide a solution for people without iOS or regular Android - the restaurants will have to decide themselves if the trust people without smartphones or without a major mobile OS.
    And yes it's becoming absurd. But as I can read on my local government's website (translation) : "In public organizations, it will be mandatory to trace clients from the 23th of October [my bad, I still have 4 days] on, and the tracing will have to be done electronically".

    I'll give it another try, and if it doesn't work, I'll negociate with the waiters.

  • @Luna
    Best of luck.
    And while negociating with the waiters, you can show off and promote the best OS for smartphones 😉

    It's sad governments have to come to this kind of solution 😞

  • Does the app connect to the internet at any point leading up to the point where you're supposed to receive an SMS?

    I would guess it's more likely that the app fails to communicate to the central server that the SMS should be sent, than that such an SMS is sent and that Ubuntu Touch fails to receive it. Could be worth looking into, if it's a more general network issue with Anbox there might be workarounds available. 🙂

  • @AppLee Haha I'll surely do that 🙂
    @potet thank you very much, you're suggesting something I absolutely didn't think about. I uninstalled Anbox yesterday after my unsuccessful tries, but I'll try again today or tomorrow (in the meantime, I have learnt how to customize your image by choosing the default Android apps you want). I don't remember if wifi was on or not, but I didn't get a message from the app telling me that an Internet connection failed. However, now that you say it, I can't think of another possibility causing the failure. I'll do some research on the forum about Anbox and the Internet 🙂

  • Having read the promotional material for that app... Doesn't it just encourage people to have gatherings indoors, exactly where they shouldn't?

    There's a bad marketing vibe going on; want to party at the club? Go ahead, you've got an app for that! I'm not criticising your choices, but your government seems out to lunch if they think this app will encourage safe social gatherings...

  • @Giiba I've thought about that too. But if I try to put myself in the government's place, I don't really know what I would do to stop the second wave of coronavirus while not locking everything down (a lot of firms are really suffering and they don't want the hospitals to be overwhelmed, too), considering that a lot of people just wrote false data down in order to avoid being contacted and put into Coventry, and that, besides social distances, the mask and hygiene, contact tracing is one of the useful measures to break transmission. And they're beginning to restrict private gatherings too, like they previously did during the spring.
    To conclude, I'd say I think that the government tries everything they can to mitigate the virus propagation without a second lockdown, but like everyone, they are blind in front of this and they don't really know what is the best thing to do, too. They could order a lockdown, but for them that would mean, in short terms, the death of a lot of firms (in culture, tourism, machine building), unemployment rise, a social crisis and I don't know what else. We already had a glimpse of what it could be during the spring.

    @AppLee about the app itself, I was wrong in saying that nothing has been made for people without smartphones (or for people with non conventional OSes). I could simply say that I can't install this app and use the alternative they put in place, but before I do that, I'd like to try and see if I truly cannot or not. So that I won't feel like lying when I'll say that I can't use it, because I hypothetically can - only returning to Android is my red line, for a lot of reasons (privacy, security, usability, and aesthetics mainly).

  • EDIT : so I've tried, and as both Yalp and Aurora crash at startup (for another similar app needed in another area in my country [it is not a joke]), and as the APK file for the app is no longer findable, I can't try to use it. So that's the end of it, I'll say I can't download it and it won't' be a lie. I'll mark this thread as solved, even though it is not in the way it should have been in the beginning.

Log in to reply