Error setup clickable



  • i try to setup clickable and following the wiki. But i get a error on the last step.

    einstein@clickablecontainer:~$ clickable setup-lxd
    No clickable.json was found, using defaults and cli args
    Going to setup the lxd container
    Asking for root to create the lxd container
    sudo: no tty present and no askpass program specified
    Command '['sudo', '/home/einstein/clickable/usdk-target', 'create', '-n', 'clickable-armhf', '-p', '78198b8305710aab554d92f9b80b913db9ade62d3eb0aaa8f9d44e92fc80d5dd']' returned non-zero exit status 1
    

    i think i need sudo, but if i start with sudo i get the message "command not found"

    any idea what is wrong on my setup?



  • It seems to me that the container was created despite the messages that you get. Have you tried using clickable now on some project?



  • @wgarcia no i don't, i will try and report what happens...

    update: i try and get this information

    einstein@clickablecontainer:~/ut-app-template$ clickable
    No lxd container exists to build in, please run `clickable setup-lxd`


  • Then, try to run "clickable setup-lxd" within a directory where you actually have a clickable.json file. Check the ubports github repositories and clone any of them which has a clickable.json for this.



  • @wgarcia now i try to setup clickable on my device not in a lxc container.

    now i get no connection to my mx4

    Successfully built package in './app.bhdouglass_1.0_armhf.click'.
    error: device not found
    Command 'adb push /home/stefan/ubports/ut-app-template/build/app.bhdouglass_1.0_armhf.click /home/phablet/' returned non-zero exit status 1
    

    if i'm looking for any devices

    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    List of devices attached 
    

    the list of devices is empty...



  • i don't enable the developer mode... sorry for this stupid question...

    now it works, i can see hello world on my phone


  • Banned

    This post is deleted!

Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.