Nexus 5 WiFi/Bluetooth Issues



  • Hello,

    I am running UT 15.04 on a Nexus 5 (Hammerhead) and I am trying to start doing some kernel development (I want to get gadgetfs working properly) however I am running into some issues that I'd like to resolve before going further.

    I have installed a custom kernel which I built from the following repository (branch ubp-5.1):

    https://github.com/ubports/android_kernel_lge_hammerhead

    I have built the kernel (no modifications) with the cyanogenmod_hammerhead_defconfig config options and successfully crafted a boot image to run on my target device.

    However, when I boot into my new kernel, bluetooth and WiFi no longer work and I see that no drivers are loaded when I run lsmod.

    Presumably there is some configuration option that I am missing in my kernel, has anyone experienced this or can anyone point me in the right direction?

    I believe that this is relevant to the error that I am getting:

    [   92.381860] SMSM: Modem SMSM state changed to SMSM_RESET.
    [   92.382434] Fatal error on the modem.
    [   92.382898] modem subsystem failure reason: dog.c:1495:Watchdog detects stalled initialization.
    [   92.383360] subsys-restart: subsystem_restart_dev(): Restart sequence requested for modem, restart_level = RELATED.
    [   92.383581] Notify: start reset
    [   92.385078] subsys-restart: subsystem_shutdown(): [ed51cc00]: Shutting down modem
    [   92.490177] pil-q6v5-mss fc880000.qcom,mss: Port f01c6200 halt timeout
    [   92.599787] pil-q6v5-mss fc880000.qcom,mss: Port f01c6280 halt timeout
    [   92.601371] smem_find(22, 40): wrong size 88
    [   92.601740] smem_find(22, 40): wrong size 88
    [   92.717946] modem_notifier_cb: sysmon_send_event error -38
    [   92.718155] M-Notify: General: 4
    [   92.719237] subsys-restart: subsystem_powerup(): [ed51cc00]: Powering up modem
    [   92.804105] pil-q6v5-mss fc880000.qcom,mss: mba: Brought out of reset
    [   93.399633] smd_pkt_open: wait on smd_pkt_dev id:0 allocation failed rc:-110
    [   93.588222] pil-q6v5-mss fc880000.qcom,mss: modem: Brought out of reset
    [   93.651109] Notify: smsm init
    [   93.688363] subsys-restart: subsys_err_ready_intr_handler(): Error ready interrupt occured for modem
    [   93.689118] subsys-restart: subsystem_restart_wq_func(): [ed51cc00]: Restart sequence for modem completed.
    
    

    Thanks!


  • Community

    Can you check to see if any modules are loaded with the normal kernel? We don't package and ship many modules, the kernel is supposed to be pretty self-contained on Ubuntu Touch.



  • With the vanilla kernel included with the install (or when I set TARGET_KERNEL_UBUNTU := true in the BoardConfig.mk file) has the following module loaded:

    bcmdhd

    When I compile my own kernel, there are no modules that show up when I run lsmod.



  • @altr0n Looking at this: https://github.com/ubports/android_kernel_lge_hammerhead/blob/ubp-5.1/arch/arm/configs/cyanogenmod_hammerhead_defconfig#L1491
    bcmdhd is being built as a module. Can you confirm that it is being built? Maybe it's just not being installed. How exactly did you "craft" the boot image?



Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.