Ubuntu-sdk IDE on ubuntu 17.10



  • Hi All,
    I have tried to install Ubuntu-sdk Ide on Ubuntu 17.10 (as guest OS with Virtualbox) but the installation fails. I got the message:
    Err:5 http://ppa.launchpad.net/ubuntu-sdk-team/ppa/ubuntu artful Release
    404 Not Found
    when i run: 'sudo apt-get update'
    I suppose that due to that error the 'ubuntu-sdk-ide' is not installed (the executable is not found).
    For the installation i have used the official commands (https://docs.ubuntu.com/phone/en/platform/sdk/installing-the-sdk).
    I know that Ubuntu-sdk ide is not currently mantained/developed and ubuntu 17.10 is now Gnome based... I would like just know if exist a workaround/solution to install it on newest Ubuntu versions.
    Currently i use Ubuntu 16.04 LST and everything works (IDE and Emulator) but i'm thinking for the future about Apps development and how i can mantain/develop my UBports apps. I haven't tryed 'clickable' framework, but IMHO i prefer have an IDE like ubuntu-sdk.
    Thanks !



  • The ppa doesn't support 17.10, if you open the ppa page you will that there aren't any packages for 17.10

    These are the list of available Ubuntu SDK, v4.1.0, which are available in that ppa:
    ubuntu-sdk-ide 4.1.0~170+201703081048~ubuntu17.04.1 Timo Jyrinki (2017-03-09)
    ubuntu-sdk-ide 4.1.0~168+201611161051~ubuntu16.04.1 Ubuntu SDK team (2016-11-18)
    ubuntu-sdk-ide 4.1.0~168+201611161046~ubuntu16.10.1 Ubuntu SDK team (2016-11-18)
    ubuntu-sdk-ide 4.1.0~168+201611161046~ubuntu14.04.1

    In theory, you could manually download the latest packages for Ubuntu SDK and which dependencies it has.
    Here is the link from where you can download the packages manually: https://launchpad.net/~ubuntu-sdk-team/+archive/ubuntu/ppa/+packages

    At first glance most likely you will need the following packages:

    • goget-ubuntu-touch
    • lxc
    • lxcfs
    • phablet-tools
    • ubuntu-sdk-dev
    • ubuntu-sdk-ide
    • ubuntu-sdk-qmake-extras
    • ubuntu-sdk-tools
    • ubuntu-touch-meta
    • ubuntu-ui-toolkit
    • unity-js-scopes

    I'm not sure about the rest of the packages there.
    Like I mentioned before, this should work in theory, in practice it might break because of different libraries in the system.

    Ofc you can get, at the ppa site, the source code and compile everything on the 17.10 machine to have it up-to-date with the machines libraries.



  • HI @vadrian89
    thanks for your reply.
    I have tryed to install Ubuntu sdk Ide on 17.04 (as guest OS with virtualbox) instead of 17.10. The installation on 17.04 works (the only note is that is necessary run manually: sudo lxd init
    to create a "Device Kit").
    About your suggestion to compile Sdk for 17.10; i'm sorry but i don't have the necessary tech skills to do that.
    The intention of my post was an investigation/test to prevent problems in case of i'll upgrade my 16.04 LTS to a newst Ubuntu version.
    I hope that someone in the future could provide a compiled version of the Sdk for the 17.04, in the meanwhile i think that i'll upgrate to 17.04



  • @fulvio If your aim is to have a stable and supported platform for utouch development and your 16.04 config works, I would remain on that rather than upgrading to 17.04, since support for that version ends in around Jan/Feb 2018, while 16.04 will be supported till April 2021.



  • Hi @arubislander
    I agree. Currently is the best choice. As you said, my intention is have a stable development environment for Utouch(UBports) if possible with Ubuntu-sdk ide. The purpose of my question was know what will happen after the end of 16.04 support about UBports app development with Ubuntu-sdk Ide.



  • @vadrian89 thanks for info, I was supporting community with small ammount of money and got OnePlus One.
    I like the interface very much but was missing an email client so wanted to start developing one in HTML5, but got to point where I found out that I need sdk, which is not compatible with 17.10.

    Now I am downloading the package, I am curious how smooth it will be to compile it.
    Or are there any news about when it will be made compatible with 17.10 - are there any plans?

    EDIT: Even a compilation process needs ubuntu-sdk-team repository, and I really wouldn't like to downgrade, so hopefully compatibility will come in near future...



  • @flowthentic Installed ubuntu-sdk with hard work on 17.10. Works good except emulator (not installable) and some errors adding some controls in using designer... boh. I'll see to develop something...



  • I'm curious about this. As long as code editor, running on desktop and running to device is working, I'll be good. I don't use other features anyway :)
    Until now I haven't upgraded to 17.10 because of Ubuntu SDK....well aside from the fact that I like Unity than Gnome 3 :D



  • thank you @rocky58 , it would be really nice if you could come up with some simplification. I have written a note for myself not to update to 18.04 (assuming it will not get supported anytime soon)



  • @flowthentic hi, I simply used old libs in 17.10 ubuntu installation. I tried on my job PC but I had no time to try on my ubuntu home PC. I'll try next days...



  • For the folks that like living a little on the wild side you could try this . It uses a xenial lxc container to run the sdk but it uses qtcreator directly from upstream qt as it's the only one that worked ok from inside the container. Feel free to swap that out in the script though.

    For the most part it works ok, there isn't USB pass through so you would still need to use clickable on the host. and for sound you need to enable networking for local servers in paprefs. It simply allows you develop build and run UT apps on your desktop if your not on 16.04 already.

    I still need to add better documentation but there should be enough to get you going. Or ping me if you hit any issues.



  • Hi @danchapman
    thanks for your work. I have tryed it but i have some "issues".
    I'm using ubuntu 17.10 (not on a virtual machine):
    I have installed lxd; executed sudo ldx init with success; restarted the pc. Until now no problems.
    Then i have executed: ./ubports-sdk-setup --target ubuntu:17.10
    and i got this:
    [ ubuntu:17.10-dev ] default lxd profile already configured

    the script exit. Seems that stops in the functions named ''check_uid_gid()": it enter but does not exit (i have placed some echo messages as debug).
    Thanks.
    PS: i'm in Ubports and Openstore telegram channels, if you want/can, you can write there.



  • @fulvio Hi there. So first you don't really want to change the target especially 17.10 as the sdk is uninstallable on that release. (as per this thread) It default's to 16.04 which runs the sdk fine and is what we will be targeting in the near future for our devices so it makes sense to just leave that as is. I added the target option in case someone wanted to use an older 15.04 cloud-image. So i would suggest to leave it as is and just run ./ubports-sdk-setup -d

    I see the bug in check_uid_gid you can just remove the exit 1 from the if block.

    I've just fixed that and pushed to github, so if you pull the latest and try again and see how it goes.



  • Also note it works a little differently now in the updated script. It will create an $HOME/UBports directory on the host which it will mount as the $HOME in the container. It also symlinks any ssh keys you might have on the host and copies over the .gitconfig. This way it keeps the container home seperate from host but can easily be accessed on the host. If you want to change the directory used for the container you can do

    export UBPORTS_HOME=$HOME/Custom/Path
    ./ubports-sdk-setup -d
    

Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.