Ubuntu Dual Boot installation usign custom server

  • Re: NEXUS 10 Dualboot Ubports image with existing Android?

    Because MultiRom is no longer maintained and last update of Lineage OS demanded a compatible recovery I cannot use MultiRom anymore as a dual boot for Lineage and UBports. UEFIDroid looks very promising but is under development and might take quite some time before usable on a Nexus 4. So I searched and found Canonicals dual boot installer.

    Just as Yougo posted over a year ago I also recently tried to make use of a custom server (http://system-image.ubports.com) in Canonical's dual boot installer, but sadly no UBports roms to choose from.
    I noticed that the contents of the file custom_server is "://system-image.ubports.com" so "http" is dropped.
    That makes me wonder if ubuntu dual installer is expecting a "https" instead of a "http". Maybe this explains why the UBport-url isn't working (yes I am a newbie probably lost in space :)).
    I also sideloaded the UBports files hoping it would trigger a 'resume install' in Ubuntu dual boot installer from the Android side. These files were downloaded to my computer first.
    This is the command I used:
    ./dualboot.sh push ubports-4838b3b40cbd569cac0f5b67ee778a993118696e366587d420830cbe2e2788cc.tar.xz device-d08eb9751a871a277abe893c4406bf26c4f239be686cfcd7c7b4f221599a826e.tar.xz version-172.tar.xz
    The process added a file 'update-command' but it did not trigger an installation.
    All files are installed to /data/data/com.canonical.ubuntu.installer/files/ubuntu_release.
    When interrupting an old Ubuntu Touch install there's another map created:

    Anybody having ideas or a workaround?

  • Most of the people I know wanting to try UT don't want to erase their existing Android. A dual boot would be awesome, is there any news on that topic recently? The EFIDroid project you're talking about looks abandoned now unfortunately.

  • @Fla The thread you just posted to is two years old so very out of date. In fact I will lock it shortly. Ubports do not support dual boot, though some have tried.
    If your still interested I would perhaps start a new thread in Off Topic and see if it gets picked up. Thanks.