Upgrade from Ubuntu Touch to UBports without a PC?



  • I have an Ubuntu Touch phone (Meizu Pro 5) which has been serving me well for the past couple of years. I would like to upgrade it to run UBports 15.04.

    My problem is that my computer cannot communicate with the Pro 5 over USB. I can charge the phone, but none of my computers recognize the phone as a USB device. Which means I cannot use the usual installation instructions to install UBports on my device.

    I discovered there is an option in the UTweak tool which allows me to mount my phone's Ubuntu Touch file system in read+write mode, which means I should be able to alter the underlying file system and system settings.

    My question is: Is there a way I can tweak the exiting/original Ubuntu Touch OS so that it uses the UBport's update channels? Basically, I need to upgrade my phone "live" without help from an outside PC. I'm wondering if I can just change a config file or over-write the upgrade app so my phone will upgrade to UBports?



  • @newguy do you have Ubuntu(any distro)on your PC or Windows?



  • @newguy if the PC( Linux) don't recognize the phone, it might help if you reboot to bootloader/fastboot mode and then you can try to flash Ubuntu recovery( in case that your PC doesn't see your phone in recovery)
    If it sees your phone in recovery (adb devices -in terminal) it's pretty straightfroward, just flash it with ubuntu-device-flash and your data, apps, settings stays intact and the phone will update to UbportsUbports.
    Ignore the --bootstrap ( otherwise it will wipe your phone completely)



  • It would be nice, if we could have the option to download and write to or prepare an USB key, plug this into the phone, boot from this into an Ubuntu system on cmd line level and run the installation from the cmd line.



  • @Stefano I am running Ubuntu MATE 17.04 on my PC. I've also tried other distros, including Linux Mint and MX Linux to rule out an OS-issue.

    I've tried booting my phone into fastboot mode and my PC doesn't detect it as a device then. Haven't tried in Recovery mode.

    Update: I looked up the instructions for recovery mode, but it requires that the PC can detect the phone in fastboot mode, which doesn't work for me. My OSes have no indication there is a device plugged in, even when using "lsusb" to see all connected devices.

    If I'm going to update, I think it will have to be by editing something on the phone itself to get it to recognize UBport's updated images.



  • @newguy Not sure if that is possible at the moment.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.