Libreoffice on OnePlus One. How launch it?



  • I install libreoffice (15.04 OTA-3) :

    libertine-container-manager create --i my --n My
    libertine-container-manager install-package -p libreoffice -i my

    But it is not shown in scope.
    How can I launch it?
    I tried:

    libertine-launch libreoffice -i my
    Traceback (most recent call last):
    File "/usr/bin/libertine-launch", line 159, in <module>
    os.execvp(args.app_exec_line[0], args.app_exec_line[0:])
    File "/usr/lib/python3.4/os.py", line 523, in execvp
    _execvpe(file, args)
    File "/usr/lib/python3.4/os.py", line 568, in _execvpe
    raise last_exc.with_traceback(tb)
    File "/usr/lib/python3.4/os.py", line 558, in _execvpe
    exec_func(fullname, *argrest)
    FileNotFoundError: [Errno 2] No such file or directory

    But it doesn't work.

    I also tried:

    phablet@ubuntu-phablet:~$ libertine-container-manager exec -i my -c libreoffice
    Failed to open display

    But it also doesn't work.



  • @abrekkos If I remember it right, graphical applications like libreoffice cannot be started like that. For libreoffice you need the scope. I think there are some other recent threads here about the scope.

    For the command lines you were trying, try starting bash that way, just to see that/how those command lines work.



  • Well, I believe the main issue is the Ubuntu store is no longer present in the system images and I am afraid the Libertine scope is not available in the Open Store. A possible solution would be to downgrade to an older release - install the scope (if the Ubuntu Store is still up) and then upgrade again. Though it would probably be easier if someone has the click package for you to install via terminal or eg. using UT Tweak app.

    PS. Here is something that may work: http://people.canonical.com/~townsend/libertine-scope/ (though it may not be the most up-to-date release, just the first I could find)



  • Thank you very much.
    I installed it by:

    pkcon install-local --allow-untrusted libertine-scope.ubuntu_1.3.2.1_armhf.click

    But there is still no any "Desktop Apps Scope". ...



  • @abrekkos Did you enabled it dragging the bottom handle on the main screen? Though if it is not there I still don't know as I haven't tested it.



  • Oh! Yes of course! Now it works!
    Many Thanks!

    Short instruction for installation LibreOffice and same desktop applications:

    1. Create libertine-container through adb shell or ssh (I named it «my»):

    libertine-container-manager create --i my --n My

    1. Install libreoffice:

    libertine-container-manager install-package -p libreoffice -i my

    1. Install libertine-scope.ubuntu_1.3.2.1_armhf.click from: http://people.canonical.com/~townsend/libertine-scope/
      By command:

    pkcon install-local --allow-untrusted libertine-scope.ubuntu_1.3.2.1_armhf.click

    1. Enable "Desktop Apps” scope by dragging the bottom handle on the main screen (swipe from bottom to top and press to star hear “Desktop Apps”).

    2. Use it.



  • Thanks, the installation of the libertine-scope also made my desktop apps visible. I can launch Gedit, for example.

    However, I cannot launch LibreOffice. In fact, I see the LibreOffice splash screen, but then there is following error message:

    "The application cannot be started.
    [context = "user"] caught unexpected
    com.sun.star.ucb.ContentCreationException:
    Cannot create folder (invalid path):"

    Do you have any idea how I can fix that? Thanks in advance.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.