Mx4 reflash with SP flash tool

  • Hi All, help needed for something obvious I must be doing wrong. I cant get sp flash tool to run on either Ubuntu (latest version) or Linux mint. I follow instruction on xda forum and bq site all seems to go well , download zip extract files to desktop or download file then follow instructions to run sp from terminal and keep hitting no such file or directory exists.
    This must be something basic I'm doing, any ideas, gave tried about 8 times today. Silly thing is used sp to put flyme back on mx4 Ubuntu edited in the first place. Thanks in advance

  • Right problem solved to a point. Mx4 now back on Ubuntu touch that does seem like a blast from the past after using ubports shows how far and how much effort has been put in so far.
    Had to use windows laptopin the end to use sp flash tool. So still need to sort out that issue on Linux. Now for the fun part getting Ubports on the mx4 😀☺

  • magic-device-tool not entering recovery. so now want to try ubports installer. which one is the right version for 32 bit laptop dual booting either latest version of ubuntu or linux mint. Have tried Appimage of ubports installer and it wont work. will try o windows laptop later. mx4 is in developermode on ubuntu touch. Oh and using terminal on Ubuntu it cant find the snap on --edge

  • success now on ubports on mx4. used linux mint in the end. had to install snapd first to install MDT devmode as a snap restarted laptop and it worked like a charm. couldnt install snap ubports installer --edge --devmode as it couldnt be found on channel --edge. still up and running now so happy ans will see how mx4 works compared to nexus5 and m10 tablet which i use daily in variuos ways. the bq 5hd is in a drawer at present.

  • First thing missing is most of the scopes that are on nexus 5 that I use eg today, calls messages. Can these be installed from somewhere I can't see them in the open app store. Iknow theres a click package to put the day back on the today scope but need the scope first. Or is this a quirk of the mx4 system its currently on the development channel r60. Thanks

  • @lakota Having checked everything again, silly error from me SP Flash Tool not suitable for 32 bit system.
    So guessing the same for ubports installer. With support from MDT for ubports stopping is there an installer that will work?, even my windows is 32 bit🙃.
    Scopes also no longer available. Still battery life good 24 hrs so far with little use to 32%. So will make the most if for as long as possible.
    Only little issues wifi drops out occasionally and takes a while to reconnect.
    update: Ubports Installer now on my Asus T100(32 bit) so no need to borrow windows laptop next time.

Log in to reply