Nexus 5 "Network Error" on cellular



  • Hello,

    I am running Ubuntu Touch version 3 on my Nexus 5 phone. When I am using a 4g cellular data connection, the browser says "Network Error" when I try to go to any web page. My cellular plan definitely includes data. In the past, I have used this phone with UBports as a wifi hotspot. I checked the network settings, and they are:

    Cellular data: On
    Data roaming: Off
    Carrier: T-Mobile
    T-Mobile GPRS (Internet & MMS): On
    T-Mobile GPRS (LTE): On
    Connection Type: 2G/3G (faster)

    If I touch "Connection Type", I get a spinning circle that never resolves itself into a settings page. Even though it says 2G/3G in the Settings page, the status bar shows several bars of T-Mobile 4G connection.

    If I turn on wifi, the browser works fine.

    If I enable data roaming, I still have the "Network Error" problem.

    I used to be able to get a data connection over cellular, but I don't use it that often, so I don't know exactly when the problem started.

    Does anyone have any suggestions about what I need to do to get a network connection over cellular?



  • @joebeach Try changing the ubports update channel to developement( settings, update, update settings at the bottom of the page, channel, development ) update the phone and try again. You should then see the 2G/3G/4G faster option againIf that fixed it you can then change the channel back to whichever you want. This seems to have worked for others



  • @Lakota thanks for the advice, I will give it a try when I get home today.



  • @lakota The development channel suggestion worked perfectly, thank you. Now I just need to decide whether to keep taking development updates or switch back to stable...



  • @joebeach glad it worked. I keep mine on development and haven't had any issues.


Log in to reply
 

Looks like your connection to UBports Forum was lost, please wait while we try to reconnect.