Phone reboots if releasing the USB connection to my computer



  • I installed UBports with the newest UBports Installer 0.1.11-beta on my OnePlus One phone. After that the phone boots fine if connected to my computer via USB. But releasing the connection, the phone reboots in a loop only showing 1+ logo.
    When trying to enable developer mode (when connected via USB) the system reboots , leaving the developer switched of.
    Does anybody noticed such a symptom? Does anybody have a hint how to fix this situation?



  • I am also experiencing the same issue with my OnePlus One.

    I tried the 15.04 and the 16.04 releases. They work great, until I unplug from my Ubuntu 18.04 box. The phone then enters a forever reboot loop.



  • @nomaran what protocol are you using when your phone is plugged? adb, mtp, ssh?



  • @advocatux I don't see how to check on the phone currently. When I was loading it it was using the ADB method to load the ROMs.



  • @nomaran do you mean that after the UT installation, when you unplugged the phone, it entered a reboot loop? If that is correct, are you sure you unplugged the phone at the right moment?



  • @advocatux If the install works when connected to the PC would a factory reset and a fresh install with wipe help?



  • @advocatux Yes, after I install UT the phone goes into a setup, while connected I downloaded a few web apps and toyed around with the OS. Once I unplugged it from my system it hangs, reboots, and continues to reboot only showing either a OnePlus logo or a black display. Until I plug it back into the computer, then it boots normally.

    @Lakotaubp I did a factory reset with wipe and no change.



  • @nomaran I don't know why those reboots are happening but it seems there's something wrong with OPOs. See for example https://forum.xda-developers.com/oneplus-one/help/rebooting-usb-unplugged-t3121356

    I wonder how is connected your phone to your computer? Is there any chance you're mounting your phone as "mass storage" or something like that and it gets mad when you unplug it without unmounting it?



  • @advocatux I tried unmounting it as well and it does the same. I'm not sure what's going on, judging from that forum post you linked it might just be something wrong with the phone.

    Guess I'll restore it, thanks for the help! Word of warning, you can't change to Developer Mode with this issue.



  • Hey everybody, sorry about the late reply. I just had a report of a successful fix for this on Telegram. The user who had the exact same problem was coming from CyanogenMod 11, while our HAL-container for the Oneplus One is based on CyanogenMod 12. What you can do is flash the firmware of CyanogenMod 12. Download this zip file, extract it and open a terminal in the folder containing the files. Then, reboot your phone to fastboot/bootloader mode and connect your device with a usb cable. Run the following commands to flash the firmware:

    fastboot flash modem NON-HLOS.bin
    fastboot flash sbl1 sbl1.mbn
    fastboot flash dbi sdi.mbn
    fastboot flash aboot emmc_appsboot.mbn
    fastboot flash rpm rpm.mbn
    fastboot flash tz tz.mbn
    fastboot flash LOGO logo.bin
    

    Making a mistake at this stage can brick your device, so please make sure no of the commands return an error. Last but not least, reboot the device.



  • @Nomaran Hello. I have the same problem with a OPO phone i have. Let us know if this works so I can try it.
    Thanks.



  • @Shannon64 Were you talking to me? The user i was supporting was able to resolve the issue with my above suggestion, so if you have the exact same issue and you also came from an operating system other than cyanogenmod 12, i recommend you try what i described. 🙂



  • @NeoTheThird Hello, thanks for the reply. My programming skills are lacking not sure how to do this. I have downloaded the files to my desktop where I unzipped them but not sure what needs to be done. Thank you.



  • @Shannon64 You need to reboot your phone to bootloader/fastboot mode (press and hold the volume up and power buttons until the phone reboots) and connect it to your pc with a usb cable. Then, open a terminal and navigate to where those files are (you said you put them on your desktop, so it's cd Desktop). Run sudo apt install fastboot to install the fastboot utility. Then run the commands from my post above and watch out for any errors. After that, hold the power button until the phone vibrates to reboot the device.



  • @NeoTheThird It Works!!!

    Thank You very much!


Log in to reply