How to transfer files from M10 tablet to Ubuntu laptop via wifi or bluetooth

  • I've tried wifitransfer and bluetooth file transfer apps, but without success. Wifitransfer works fine for moving files from my laptop to my Ubuntu tablet, but I can't move them in the opposite direction. I also tried Bluetoothfiletransfer, but I couldn't get that to work either. Any suggestions anyone please?anyone

  • @dtarrant Well I just figured out how to do this using wifitransfer. You need to use UT file manager and enable show hidden files and full access. Then copy the file or folder you want to move into /.local/share/wifitransfer.sil and then you can access this directory from your Ubuntu laptop. How cool is that?

  • @dtarrant : Hello

    With my BQ E5 UT OTA11, I used samba to transfer files and folder to or from my local network.
    Unfortunately, since OTA??, this didn't work and I don't know why. The filemanager displays smb://0 then quits without any error message as soon as I try to browse the network.
    So I gave a try to WifiTransfer, and next to uFtp. Here is the status ...

    WifiTransfer :

    • acts like a server => use Filezilla on the laptop
    • the Filezilla UI allows multiple selection of files and folders and make things easy
    • I experienced "silent errors" of transfer, often for a bunch of photos which is easy to detect
      => you always must verify the integrity of what you have transfered

    uFtp :

    • acts like a client => use Filezilla Server on the laptop
    • I never succeeded to transfer a folder or multiple files from Laptop to Phone
    • I never experiment "silent errors"
    • uFtp makes a temporary copy of all what you send in his folder. This is a huge drawback !

    Confinement :
    WifiTransfer and uFtp are confined as usual so they can only access to the .local/share/<appname>/ folder.
    The only choice is to use UT file manager and enable show hidden files and full access as you say.
    Here is a tiny workaround for the "show hidden files" constraint. Using Terminal, create symbolic links :

    • ln -s ~/.local/share/wifitransfer.sil/ ~/Ftp
    • ln -s ~/.local/share/ftpmanager.costa/ ~/uFtp

    WifiTransfer gives a better workaround with this example of modified apparmor parameters
    WifiTransfer.apparmor (used by default)
    "policy_groups": [
    "policy_version": 1.2
    You can replace the content of the above file by something like :
    WifiTransfer.apparmor.openstore (proposed modified version)
    "policy_groups": [
    "policy_version": 1.2,
    "write_path": ["@{HOME}/"],
    "read_path": ["@{HOME}/"]
    I suggest to be more restrictive for the write_path with something like ["@{HOME}/FTPin/"] after creating the FTPin folder.

    Hope this helps

  • Nota :

    • It would be better to understand why samba doesn't work ... :o(
    • Maybe SSH is better than FTP ? Have a look there

  • @dtarrant : Did you find a convenient solution ?

  • @pulsar33 So far, I have continued to use the method I initially described whereby I copy the files to be transferred into .local/share/wifitransfer.sil and then use wifitransfer to move them from the tablet to the laptop. I didn't have the courage to try your suggestions as I felt that this would be taking me out of my comfort zone and I would be risking screwing up my Ubports system. For example, I didn't recognize "filezilla". The file manager on my laptop is nautilus. I use my tablet as a daily driver as it's more convenient for web browsing and messaging etc than my laptop. I'm typing this reply on my Ubports M10 tablet. Anyway, many thanks for taking the trouble to reply. Your suggestions were appreciated but just a bit too scary for me to be prepared to experiment with.

    You mentioned samba. I use samba to move files between my laptop and my desktop PC. I've no idea if samba is installed on my tablet. However, I've noted that the UT file manager crashes whenever I select the network option. That's what originally prompted me to try wifitransfer.

Log in to reply